Перейти к содержанию
Banditman

подскажите как исправить ошибку!!!???

Рекомендуемые сообщения

Подскажите как исправить ошибку! Залил файлы на хостинг, запускаю suvenir-74.ru/install.php или просто suvenir-74.ru вылазит ошибка 500! Если удалить файл .htaccess то ошибка пропадает и начинается установка но не соблюдается magic_quotes_gpc Off пишет что он включён! ставлю обратно файл .htaccess и опять ошибка 500! Облазил весь хостинг PHP.ini не нашёл! Что делать? Заранее спасибо!!!

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Вроде по дефолту файт .htaccess называется .htaccess.txt тоесть ставишь без него, а потом уже переименовываешь в .htaccess

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

То есть движок поставить без .htaccess а потом после установки записать его туда?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Да, сначала не трогай .htsccess а уже после установки переименуй .htaccess.txt в .htaccess

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Установил, переименовал опять лезет ошибка 500 !!!

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Пробуй комментировать по одной строчке в .htaccess до исчезновения ошибки.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Извеняюсь за глупый вопрос, я начинающий, как коментировать? Можно пример!!!

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Перед каждой строчкой ставишь знак #. Например последняя строчка закомментирована.

RewriteEngine OnRewriteBase / RewriteCond %{REQUEST_FILENAME} !-fRewriteCond %{REQUEST_FILENAME} !-d#RewriteRule ^(.*)?*$ index.php?_route_=$1 [L,QSA]

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Закомментировал все строчки ошибка пропала! А это не на что в будушем не повлияет!#php_flag magic_quotes_gpc #php_flag register_globals off #php_value magic_quotes_gpc Offphp_value magic_quotes_gpc off #php_flag safe_mode Off #php_flag session.use_cookies On #php_flag session.use_trans_sid Off #php_value default_charset UTF-8 #php_value memory_limit 64M #php_value max_execution_time 18000 #php_value max_upload_filesize 100M #php_value mysql.connect_timeout 20 #php_value session.gc_maxlifetime 12000000 Options +FollowSymlinks RewriteEngine On RewriteBase / RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule ^(.*)?*$ index.php?_route_=$1 [L,QSA]

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

:(

#php_flag magic_quotes_gpc#php_flag register_globals off#php_value magic_quotes_gpc Offphp_value magic_quotes_gpc off#php_flag safe_mode Off#php_flag session.use_cookies On#php_flag session.use_trans_sid Off#php_value default_charset UTF-8#php_value memory_limit 64M#php_value max_execution_time 18000#php_value max_upload_filesize 100M#php_value mysql.connect_timeout 20#php_value session.gc_maxlifetime 12000000

Это похоже с файла php.ini

А это из .htaccess

Options +FollowSymlinks<IfModule mod_rewrite.c>RewriteEngine OnRewriteBase /RewriteCond %{REQUEST_FILENAME} !-fRewriteCond %{REQUEST_FILENAME} !-dRewriteRule ^(.*)?*$ index.php?_route_=$1 [L,QSA]</IfModule>

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

А у меня почему то всё в одном может их разделить и заново переустановить движок?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Уважаемый Richi, если бы вы потрудились глянуть svn или последние обновления, то увидели бы изменения в .htaccessBanditman, подобный вопрос уже задавали, но увы, после моей просьбы пропали..Просьба: закомментировать все строки и раскомментировать по одной до появления ошибки, дабы узнать какая именно строка вызывает ошибку. И далее закомментировать с ошибкой и проверить другие строки.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

#php_flag magic_quotes_gpc

#php_flag register_globals off

#php_value magic_quotes_gpc Offphp_value magic_quotes_gpc off

#php_flag safe_mode Off

#php_flag session.use_cookies On

#php_flag session.use_trans_sid Off

#php_value default_charset UTF-8

#php_value memory_limit 64M

#php_value max_execution_time 18000

#php_value max_upload_filesize 100M

#php_value mysql.connect_timeout 20

php_value session.gc_maxlifetime 12000000 ------ После того как раскомментировал ошибка появилась

Options +FollowSymlinks

RewriteEngine On

RewriteBase /

RewriteCond %{REQUEST_FILENAME} !-f

RewriteCond %{REQUEST_FILENAME} !-d

RewriteRule ^(.*)?*$ index.php?_route_=$1 [L,QSA]

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Народ подскажите плиз что делать с этой ошибкой из-за этой строчки! Если закомментировать все строки сильно это повлияет на безопасность или работоспособность?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Всем спасибо! Проблему удалось решить спомощью тех. поддержки, когда они мне вынесли файл php.ini в корн. директорию хостинга!

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Ошибка вылазит только если раскомментировать "php_value session.gc_maxlifetime 12000000"? Что если только одну эту строку оставить закомментированной?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Простите за вопрос не в тему а какие преимущества обьединения файлов php.ini и .htaccess в 1 файл? :)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Ошибка вылазила если раскомментировать любую из этих строк!

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Поскольку наши Гуру пока заняты я б на твоем месте разделил всю кучу на 2 файлика как и было по старинке. Это записать в файл php.ini

php_flag magic_quotes_gpcphp_flag register_globals offphp_value magic_quotes_gpc Offphp_value magic_quotes_gpc offphp_flag safe_mode Offphp_flag session.use_cookies Onphp_flag session.use_trans_sid Offphp_value default_charset UTF-8php_value memory_limit 64Mphp_value max_execution_time 18000php_value max_upload_filesize 100Mphp_value mysql.connect_timeout 20php_value session.gc_maxlifetime 12000000
а это в .htaccess
Options +FollowSymlinksRewriteEngine OnRewriteBase /RewriteCond %{REQUEST_FILENAME} !-fRewriteCond %{REQUEST_FILENAME} !-dRewriteRule ^(.*)?*$ index.php?_route_=$1 [L,QSA]

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Richi, гениально :) посмотрите формат файла php.inip.s.: тогда в дистрибутиве просто закомментирую эти все строки, дабы проблем небыло, но такие проблемы далеко не на всех хостингах

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Вся эта дрибедень (ошибка) вылазила из-за модуля magic_quotes_gpc т.к. он был on, доступа к файлу php.ini я не имел, после того как тех. поддержка хостинга вынесла мне файл php.ini в корень хостинга и отключив модуль magic_quotes_gpc , то ошибка была решена. Всем спасибо за ценную информацию!!! :(

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.