net4xx

Проблема при наличии слеша на конце страниц

Рекомендуемые сообщения

net4xx    0

Приветствую!

Прошу помощи. Версия Opencart 1.5.4.1

 

Настроен SEO_PRO. Без SEO_PRO проблема та же. В таблицы все прописано. УРЛ формируются как надо.

НО! При наличии в урл страницы "/"  страницы грузятся без стилей. Файл htaccess тоже настроен basedir прописан, все как положено.

 

В лог сайта идут такие сообщения:

 

Для страницы www.mysite.ru/login/

File does not exist: /home/c/cl22573/public_html/login/catalog/view/javascript/jquery/fancybox/jquery.fancybox.pack.js

 

Для страницы www.mysite.ru/admin/
File does not exist: /home/c/cl22573/public_html/admin/catalog/view/theme/default/image/loading.gif

Для страницы www.mysite.ru/constructor/
File does not exist: /home/c/cl22573/public_html/constructor/catalog/view/javascript/jquery/ui/themes/ui-lightness/jquery-ui-1.8.16.custom.css
File does not exist: /home/c/cl22573/public_html/constructor/catalog/view/javascript/common.js
 

Подскажите, в каком направлении копать? Может кто сталкивался с данной проблемой?

Спасибо.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
net4xx    0

Приветствую!

Прошу помощи. Версия Opencart 1.5.4.1

 

Настроен SEO_PRO. Без SEO_PRO проблема та же. В таблицы все прописано. УРЛ формируются как надо.

НО! При наличии в урл страницы "/"  страницы грузятся без стилей. Файл htaccess тоже настроен basedir прописан, все как положено.

 

В лог сайта идут такие сообщения:

 

Для страницы www.mysite.ru/login/

File does not exist: /home/c/cl22573/public_html/login/catalog/view/javascript/jquery/fancybox/jquery.fancybox.pack.js

 

Для страницы www.mysite.ru/admin/

File does not exist: /home/c/cl22573/public_html/admin/catalog/view/theme/default/image/loading.gif

Для страницы www.mysite.ru/constructor/

File does not exist: /home/c/cl22573/public_html/constructor/catalog/view/javascript/jquery/ui/themes/ui-lightness/jquery-ui-1.8.16.custom.css

File does not exist: /home/c/cl22573/public_html/constructor/catalog/view/javascript/common.js

 

Подскажите, в каком направлении копать? Может кто сталкивался с данной проблемой?

Спасибо.

 

 

Разобрался.

 

В шаблоне путь до стилей и скриптов был прописан без слеша вначале, вот и проблема.

Было например: catalog/.../.../...

Сделал так: /catalog/.../.../...   и все заработало

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти


  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу