Перейти к содержанию
joe

[Решено] Could not load model design/layout

Рекомендуемые сообщения

Вообщем при заходе на любую страницу сайта вылетает следующая ошибка:

 

Notice: Error: Could not load model design/layout! in /home/wheels1/creativewheels.ru/docs/vqmod/vqcache/vq2-system_engine_loader.php on line 51

 

Произошло это после того как я добавил новую категорию.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Что делали со своим дизайном?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Кстати, как вариант, можно попробовать полностью очистить папку /vqmod/vqcache...

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

папку чистил, не помогло, с дизайном собственно в хедере изменил ссылку на новую категории и понеслось...

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

А можно код из header.tpl?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

<!DOCTYPE html>
<html dir="<?php echo $direction; ?>" lang="<?php echo $lang; ?>">
<head>
<meta charset="UTF-8" />
<title><?php echo $title; ?></title>
<base href="<?php echo $base; ?>" />
<?php if ($description) { ?>
<meta name="description" content="<?php echo $description; ?>" />
<?php } ?>
<?php if ($keywords) { ?>
<meta name="keywords" content="<?php echo $keywords; ?>" />
<?php } ?>
<?php if ($icon) { ?>
<link href="<?php echo $icon; ?>" rel="icon" />
<?php } ?>
<?php foreach ($links as $link) { ?>
<link href="<?php echo $link['href']; ?>" rel="<?php echo $link['rel']; ?>" />
<?php } ?>
<link rel="stylesheet" type="text/css" href="catalog/view/theme/default/stylesheet/stylesheet.css" />
<link rel="stylesheet" type="text/css" href="catalog/view/theme/default/stylesheet/website.css" />
<link rel="stylesheet" type="text/css" media="screen, projection, print" href="karusel.css" />
<?php foreach ($styles as $style) { ?>
<link rel="<?php echo $style['rel']; ?>" type="text/css" href="<?php echo $style['href']; ?>" media="<?php echo $style['media']; ?>" />
<?php } ?>
<script type="text/javascript" src="catalog/view/javascript/popup.js"></script>
<script type="text/javascript" src="catalog/view/javascript/jquery/jquery-1.7.1.min.js"></script>
<script type="text/javascript" src="catalog/view/javascript/jquery/ui/jquery-ui-1.8.16.custom.min.js"></script>
<link rel="stylesheet" type="text/css" href="catalog/view/javascript/jquery/ui/themes/ui-lightness/jquery-ui-1.8.16.custom.css" />
<script type="text/javascript" src="catalog/view/javascript/jquery/ui/external/jquery.cookie.js"></script>
<script type="text/javascript" src="catalog/view/javascript/jquery/colorbox/jquery.colorbox.js"></script>
<link rel="stylesheet" type="text/css" href="catalog/view/javascript/jquery/colorbox/colorbox.css" media="screen" />
<script type="text/javascript" src="catalog/view/javascript/jquery/tabs.js"></script>
<script type="text/javascript" src="catalog/view/javascript/common.js"></script>
<?php foreach ($scripts as $script) { ?>
<script type="text/javascript" src="<?php echo $script; ?>"></script>
<?php } ?>

<script type="text/javascript" src="catalog/view/javascript/jquery.tinycarousel.min.js"></script>
<script type="text/javascript">
    $(document).ready(function(){
                
        $('#slider1').tinycarousel({ display: 2 });
        
    });
</script>
        <script type="text/javascript"><!--
$('.colorbox').colorbox({
    overlayClose: true,
    opacity: 0.5
});
//--></script>
                 
<!--[if IE 7]>
<link rel="stylesheet" type="text/css" href="catalog/view/theme/default/stylesheet/ie7.css" />
<![endif]-->
<!--[if lt IE 7]>
<link rel="stylesheet" type="text/css" href="catalog/view/theme/default/stylesheet/ie6.css" />
<script type="text/javascript" src="catalog/view/javascript/DD_belatedPNG_0.0.8a-min.js"></script>
<script type="text/javascript">
DD_belatedPNG.fix('#logo img');
</script>
<![endif]-->
<?php echo $google_analytics; ?>
</head>
<body>
<div id="container1">
<div id="header">


  <?php if ($logo) { ?>
  <div id="logo"><a href="http://creativewheels.ru/"><img src="<?php echo $logo; ?>" title="<?php echo $name; ?>" alt="<?php echo $name; ?>" /></a></div>
  <?php } ?>
  <?php echo $cart; ?>
<div class="menu">
<a href="http://creativewheels.ru/"><div class="menu_button">Главная</div></a>
<a href="http://creativewheels.ru/litie_diski/"><div class="menu_button">Диски</div></a>
<a href="http://creativewheels.ru/dostavka.html"><div class="menu_button">Доставка</div></a>    
<a href="http://creativewheels.ru/contacts.html"><div class="menu_button">Контакты</div></a>
<div class="menu_button1"></div>
</div>
</div>

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

А меню у Вас по дэфолту выводится? Т.е., добавляете в админке, отображается?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Скажите, а это ссылки такие или же это просто не много урезано?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

У вас неправильный код. Должно быть так (ссылки поправите сами):

<div class="menu">
 <a href="http://creativewheel...авная'>http://creativewheel...авная">Главная</a>
 <a href="http://creativewheel...Диски">Диски</a>
 <a href="http://creativewheel...а">Прочее</a>
</div>

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

редактор урезал, вот так они вглядят:

 

<a href="http://creativewheels.ru/">

<div class="menu_button">Главная</div>

</a>
<a href="http://creativewheels.ru/litie_diski/">

<div class="menu_button">Диски</div>

</a>
<a href="http://creativewheels.ru/dostavka.html">

<div class="menu_button">Доставка</div>

</a>    
<a href="http://creativewheels.ru/contacts.html">

<div class="menu_button">Контакты</div>

</a>

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Проблема не в них т.к. я пробовал их даже сбивать,

проблема я думаю в этом: Could not load model design/layout

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

 

У вас неправильный код. Должно быть так (ссылки поправите сами):

<div class="menu">
 <a href="http://creativewheel...авная'>http://creativewheel...авная">Главная</a>
 <a href="http://creativewheel...Диски">Диски</a>
 <a href="http://creativewheel...а">Прочее</a>
</div>

Но раньше-то работало) я пробовал полностью убирать менюшку, не в ней проблема

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Залейте в папку catalog\view\theme\ВАША_ТЕМА\template\common\ оригинальный файл header.tpl (от вашего шаблона) и посмотрите, пропадет ли ошибка.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Залейте в папку catalog\view\theme\ВАША_ТЕМА\template\common\ оригинальный файл header.tpl (от вашего шаблона) и посмотрите, пропадет ли ошибка.

нет, не пропала

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Сравните ваши файлы system\engine\loader.php и catalog\model\design\layout.php с оригинальными из дистрибутива.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Проблема не в них т.к. я пробовал их даже сбивать,

проблема я думаю в этом: Could not load model design/layout

 

А вообще присутствие всего этого есть?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

да, вообщем я думаю проще переустановить opencart

скажите, если я скопирую шаблон и сделаю бэкап из админки этого достаточно будет чтобы восстановить сайт?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

У меня была подобная ошибка, но я нашел выход из этой ситуации следующим образом.

1. Удалил сайт из корневого каталога кроме директории /image/ - где хранятся картинки, и оставил файл /admin/config.php config.php, который в корне.

2. Из "коробки" распаковал (у меня 1.5.4.1) Opencart. Папку /image/ вообще не закидывал, так как она не нужна, потому-то есть уже директория с нужными мне картинка.

3. После копирования подложил конфигурационные файлы по своим места /admin/ и корень сайта.

4. Этап проверки на работоспособность. Результат: полностью работоспособный сайт.

 

З.Ы. Тока БД не грохните! Т.е., через phpmyadmin. Так, случайно! ) Можно ещё и через админку проBackUP`ить её! )

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Проблема не в них т.к. я пробовал их даже сбивать,

проблема я думаю в этом: Could not load model design/layout

Правильно думаешь! В этом проблемма!

Зайди в папку /catalog/model/design/ и посмотри есть ли у тебя там вообще файл layout.php

 

В ошибке ж написано, если перевести, "НЕ МОГУ ЗАГРУЗИТЬ МОДЕЛЬ DESIGN/LAYOUT"...

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Во блин, случайно зашёл в папку /catalog/, так там вообще нет папки /model/, залил её, всё работает)), я был уверен что она есть

странно, куда она делась?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Вот "игры" к чему и приводят! )

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Гость
Эта тема закрыта для публикации ответов.

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.