Jump to content
Sign in to follow this  
eviltwin

[Решено] Косяк при сохранении товара

Recommended Posts

При сохранении товара вылетает такая ошибка:

Notice: Undefined index: seo_title in /var/www/user5023/data/www/домен/vqmod/vqcache/vq2-admin_model_catalog_product.php on line 139Notice: Undefined index: seo_h1 in /var/www/user5023/data/www/домен/vqmod/vqcache/vq2-admin_model_catalog_product.php on line 139Warning: Cannot modify header information - headers already sent by (output started at /var/www/user5023/data/www/домен/admin/index.php:83) in /var/www/user5023/data/www/домен/vqmod/vqcache/vq2-system_engine_controller.php on line 28Warning: Cannot modify header information - headers already sent by (output started at /var/www/user5023/data/www/домен/admin/index.php:83) in /var/www/user5023/data/www/домен/vqmod/vqcache/vq2-system_engine_controller.php on line 29

До этого были проблемы с загрузкой фотографий, но частично решил проблему (правда иногда при выборе папки с фотами, в менеджере изображений отображаются не все).

После этой ошибки пробую снова зайти в админку, пишет:

- Список товарод обновлен

- Неправильная токен сессия. Авторизуйтесь снова.

Я уже убился нафег с этими ошибками.

Сайт был перенесен с другого хостинга.

Хрень такая появилась когда я перустановил vqmod командой: домен/vqmod/install

Но я так понимаю данную процедуру можно делать сколько угодно раз?

Помогите плиз знатоки, намучался уже...

Share this post


Link to post
Share on other sites

В папке vqmod есть лог ошибок. Возможно vqmod не работает полностью. Еще стоит почистить vqmod/vqcache

Share this post


Link to post
Share on other sites

У меня такое было когда я устанавливал на окстор модуль, сделанный под чистый опенкарт, т.е. он перезаписывал файлы окстора. Я так лоханулся с имагеменеджером, у тебя возможно были файлы в вкьюмоде,котые изменяли файлы под чистый опенкарт и после установки вкьюмода он заработал,проверь что именно за xml лежат,что они заменяют и нужны ли они вообще

Share this post


Link to post
Share on other sites

нет лога там.

переставил по новой vqmod, та же хрень. чистил vqкэш.

из модов vq-шных у меня там:

cache_manager.xml

export.xml

fix_image_cache_rights_problem.xml

vqmod_admin_filter_products_by_category_1_5_2_1.xml

имагеменеджер мне моск весь вынес, я хостера задолбал. ибо криво создаюцо папки

Share this post


Link to post
Share on other sites

а движок у тебя ocstore или чистый opencart?

Share this post


Link to post
Share on other sites

слушай друг подскажи еще как вернуть стандартный имагеманагер?

Share this post


Link to post
Share on other sites

качал от сюда, версия 1.5.3.1

я про это и говорил, стоит ocstore, а модуль скачали для opencart, он кое-что затер.

выход сложно теперь найти, можно скачать заново этот модуль и смотреть какие он файлы заменяет, и каждый из таких файлов заменять аналогичным, но из сборки ocstore.

или заново весь магазин поставить.

или скачать этот менеджер https://opencartforum.com/files/file/534-image-manager-для-ocstore-153x-154x-мультизагрузка-изображений-в-админ/ и поставить его сверху, он уже настроен под ocstore, возможно вылечит, но делайте бэкапы, т.к. возможно он вообще все убьет.

Share this post


Link to post
Share on other sites

Всем спасибо большое за советы!

Вопрос решился.

Модератора прошу закрыть тему.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

On our site, cookies are used and personal data is processed to improve the user interface. To find out what and what personal data we are processing, please go to the link. If you click "I agree," it means that you understand and accept all the conditions specified in this Privacy Notice.