Jump to content
Sign in to follow this  
eargonx

Ошибка при включении модуля seopro

Recommended Posts

Добрый день! На сайте установлен модуль seo pro, версия магазина 2.1.0.2.1, ошибка в следующем, когда в админке включаешь тип ЧПУ "seopro", перестает работать главная страница, а точнее происходит редирект на страницу /%2F/ с ошибкой "The requested URL /// was not found on this server." При том что остальные страницы по старым ссылкам работают, кроме главной. Пробовал переустанавливать модуль, не помогло. В чем может быть причина?

Share this post


Link to post
Share on other sites

а базе у вас не пустое значение а пробел

update oc_url_alias set keyword = '' where query = 'common/home'

Share this post


Link to post
Share on other sites
11 минут назад, spectre сказал:

а базе у вас не пустое значение а пробел

update oc_url_alias set keyword = '' where query = 'common/home'

Попробовал выполнить запрос, не помогло.

Share this post


Link to post
Share on other sites

кеш очистите сеопро

Share this post


Link to post
Share on other sites

Благодарю, помогло. Однако теперь слайдер сам перелистывает изображения товара, а в коде вот такие дублирующие строки:

 

1.thumb.png.9cf0bb3395c061dc4f6405534ee2a4fa.png

Share this post


Link to post
Share on other sites

А какая связь? :)

Share this post


Link to post
Share on other sites

не вижу) возможно кривой модуль стоит, потому что при отключенном чпу такого нету)

Share this post


Link to post
Share on other sites

Обнаружил еще одну проблему, если модуль сеопро отключен, то в категориях не работает сортировка новостей, а также разбивка по количеству на страницу. Выдает ошибку 404. Если включить модуль, сортировка и разбивка работают, но сайт некорректно себя ведет, постоянно грузятся яваскрипты.

Сайт: https://kalibri.top/new/

Может кто сталкивался с подобной проблемой?

Share this post


Link to post
Share on other sites

сломали формирование ссылок

Share this post


Link to post
Share on other sites

А как это исправить или хотя бы в каком файле копать?

Share this post


Link to post
Share on other sites

в product/category.php

 

А может еще где, и кто и что

Share this post


Link to post
Share on other sites

 

28 минут назад, chukcha сказал:

в product/category.php

 

А может еще где, и кто и что

пробовал менять на оригинальный из дистрибютива не помогло(( с category.tpl тоже самое

Share this post


Link to post
Share on other sites
В 23.01.2018 в 13:24, spectre сказал:

а базе у вас не пустое значение а пробел

update oc_url_alias set keyword = '' where query = 'common/home'

А мне это в 3 опенкарта версии не помогает, уже голову сломала или только гугл браузера хром, перезагрузка компа не помогает :(

Edited by Marianna

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

On our site, cookies are used and personal data is processed to improve the user interface. To find out what and what personal data we are processing, please go to the link. If you click "I agree," it means that you understand and accept all the conditions specified in this Privacy Notice.