NaizeR

Новичок
  • Публикаций

    5
  • Зарегистрирован

  • Посещение

Репутация

0 Обычный

Информация о NaizeR

  • Звание
    Новичок
  1. OpenCart Exchange 1C

    Проблема решена, спасибо огромное Serdes. Дело было в проверке артикула
  2. Serdes

    Спасибо большое Serdes, очень быстро выручил с OpenCart Exchange 1C !!!
  3. OpenCart Exchange 1C

    В кэше файлы есть, цены и кол-во (все товары 1 шт) тоже заданы для товаров. В БД в таблице oc_product_to_1c - 15 записей у всех почему то product_id = 1 , а в oc_product_to_store одна запись 0 0.
  4. OpenCart Exchange 1C

    в журнале ошибок OC : Найден товар: ХХХ арт: 1C UUID: 0637911a-6240-11e3-8189-ac220b843e10 2013-12-12 12:08:39 - Окончен разбор файла: import.xml 2013-12-12 12:08:39 - Начат разбор файла: offers.xml 2013-12-12 12:08:39 - Окончен разбор файла: offers.xml vqmod/logs пустая В логах апача нет ошибок. Так же как и в таблице oc_products, 0 записей. Хотя почему то с демо-базы 1с выгрузка проходит. правда с ошибками. Появляются производители, категории и товары Upd: Обновил модуль с GitHub. Добавил в таблицу product_to_category поле main_category ( до этого было только product_id и category_id). В настройках выставляю все галочки кроме SEO и водяных знаков. Делаю полную выгрузку в 1С. В журнале ошибок: ... 2013-12-12 16:17:53 - Найден товар: XXX арт: 1C UUID: 0637911a-6240-11e3-8189-ac220b843e10 2013-12-12 16:17:53 - Окончен разбор файла: import.xml 2013-12-12 16:17:53 - Начат разбор файла: offers.xml 2013-12-12 16:17:53 - Товар: [uUID]:063790f3-6240-11e3-8189-ac220b843e10 В логах Call to undefined method ModelCatalogProduct::getProductMainCategoryId() Реализации метода нигде в OC нет В /admin/model/catalog/product.php дописал: public function getProductMainCategoryId($product_id) { $product_category = $this->db->query("SELECT main_category FROM " . DB_PREFIX . "product_to_category WHERE product_id = '" . (int)$product_id . "'"); return $product_category; } Из 15 товаров загружается почему то только 1
  5. OpenCart Exchange 1C

    Здравствуйте. При выгрузке 1с ошибок не выдает, пишет выгружено товаров ХХ, выгружено картинок ХХ. Но на сайте товары не появляются. в логах ошибок не пишет. OC 1.5.6 exchange 1.5.4.1 dev 51 vQmod 2.3.2 В чем может быть дело? Возможно есть ограничение на размер выгрузки ? Если делать выгрузку в каталог, то все занимает около 60 мб. Так же, если делать ручной импорт, никакого результата. Спасибо