Перейти к содержанию
jimmie

SEO Pro перестал устанавливать SEO URL для новых товаров

Рекомендуемые сообщения

При заведении новых товаров в поле SEO URL, вместо корректных адресов, как обычно, начали выставляться цифры- от "-1" и так дальше. Например: moisite.com/-1  moisite.com/-2

SEO Pro установлен и в настройках вкладки "Сервер" включен. 

В чем может быть ошибка?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

это не seo pro это какой-то другой модуль у вас

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

deadcow не установлен.

Понял, что ситуация, видимо, нетиповая, поиск ничего не дал, буду искать программиста

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

@jimmie присоединюсь к предыдущим ораторам: это 100% проблема в другом модуле :)

 

Так как я сам писал подобный модуль по генерации ЧПУ (SEO URL Generator FREE), то уверен, что модуль даже работает. Ведь Вам генерируются уникальные ЧПУ moisite.com/-1 и moisite.com/-2. Проблема, скорее всего в другом:

 

а) Либо какие-то настройки слетели (к примеру, формула, по которой должны генерировать ЧПУ товаров)

б) Либо в карточке товара не заполнены нужные данные (название товара)

в) Либо был снесен язык, заменен id языка при обновлении сайта


Чтобы установить точно, какой модуль у Вас занимается генерацией ЧПУ, пришлите снимок списка модификаторов.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Есть подозрение, что это какой-то модуль, Смотрит в таблицу урлов, Если есть дубль то добавляет число
в данном случае, он видит пустой сеоурл, и добавляет -N

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
51 минуту назад, SergeTkach сказал:


Чтобы установить точно, какой модуль у Вас занимается генерацией ЧПУ, пришлите снимок списка модификаторов.

 

Спойлер

 

 

Снимок экрана 2017-12-16 в 12.17.03.png

Снимок экрана 2017-12-16 в 12.17.28.png

Снимок экрана 2017-12-16 в 12.17.56.png

Снимок экрана 2017-12-16 в 12.18.13.png

Снимок экрана 2017-12-16 в 12.18.30.png

Снимок экрана 2017-12-16 в 12.18.46.png

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

У меня есть подозрение, что генерацией УРЛ занимается for_julynews.xml (Auto Generate SEO URL for july News)

Хотя, если шаблон дизайна не называется july News, то это может быть модификатор, который генерит ЧПУ чисто для модуля новостей темы July.

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
2 минуты назад, spectre сказал:

так написано же news

 

Та мало ли...

Другого модификатора, который указывал бы на генерацию ЧПУ вроде как не заметил.

Разве что tags_2_0.xml может быть

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Хм, а ЧПУ генерятся по мере ввода названия или по факту сохранения товара?

 

Если первое, то необходим код модифицированного файла admin/view/template/catalog/product_form.tpl. По идее это будет vqmod/vqcache/vq2-system_storage_modification_admin_view_template_catalog_product_form.tpl

 

Если второе - то admin/controller/catalog/product.php (vqmod/vqcache/vq2-system_storage_modification_admin_controller_catalog_product.php)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Проблему решил @spectre - проблема оказалась в deadcow, как он изначально и предположил- в админке он был у меня выключен, но был вшит в код. Спасибо всем за интерес к теме и уделенное время!   

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Так и что было не так-то, что deadcow не срабатывал корректно?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
36 минут назад, SergeTkach сказал:

Так и что было не так-то, что deadcow не срабатывал корректно?

В 2х словах было нечего генерировать

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Похожий контент

    • От zaq
      При включении seo pro не выводит товары с одинаковыми тегами. Да и на самой странице поиска ничего не находит. Через умный поиск в хейдере, товары находит. Как исправить? 

    • От SergeTkach
      Скачать/Купить дополнение


      SEO PRO Cache Auto Destroy
      Модификатор SEO PRO Cache Auto Destroy автоматически чистит кеш ЧПУ модуля SEO PRO в системе OpenCart 2.3.x. после каждого добавления или редактирования:
      Товара Категории Производителя Статьи ( Инфо-страницы ) Модуля блога и новостей NewsBlog  
      В поддержке моих модулей по автоматической генерации SEO URL'ов (в том числе и к бесплатной версии) часто приходит вопрос с недоумением, почему товар не отображается по новому ЧПУ?
       
      Потому что необходимо чистить кеш!
       
      Чтобы не забывает его чистить после каждого добавления товаров, проcто установить данный модификатор.
      Добавил SergeTkach Добавлено 02.04.2018 Категория SEO, карта сайта, оптимизация Системные требования Сайт разработчика http://sergetkach.com/ Старая цена Метод активации Без активации Ioncube Loader Нет OpenCart 2.3
      2.2
      2.1 ocStore 2.3
      2.2
      2.1 OpenCart.Pro, ocShop Opencart.pro 2.3
      Opencart.pro 2.1  
    • От SergeTkach
      Модификатор SEO PRO Cache Auto Destroy автоматически чистит кеш ЧПУ модуля SEO PRO в системе OpenCart 2.3.x. после каждого добавления или редактирования:
      Товара Категории Производителя Статьи ( Инфо-страницы ) Модуля блога и новостей NewsBlog  
      В поддержке моих модулей по автоматической генерации SEO URL'ов (в том числе и к бесплатной версии) часто приходит вопрос с недоумением, почему товар не отображается по новому ЧПУ?
       
      Потому что необходимо чистить кеш!
       
      Чтобы не забывает его чистить после каждого добавления товаров, проcто установить данный модификатор.
    • От AntonMuxa
      Все здравствуйте форумчане. Вопрос такой: seo pro работает не полностью. Движок ocStore 2.1.0.2 стоит seo pro от freelancer. На товарах и категориях сео срабатывает все хорошо, но вот когда я устанавливаю баннеры на главную к ссылкам добавляется index.php?route= Например если ссылка для баннера /manufacturer то на сайте она выглядит так
      домен/index.php?route=/manufacturer Что может быть? Может кто с таким сталкивался? Любые идеи и советы приму. Спасибо
    • От owner25
      Всем привет!
      Нужна ваша помощь, в шаблоне fastor есть встроенный модуль quickview.
      Проблема в следующем, вот так модуль отображается без ЧПУ или со стандартным:

       
      А так с Seo Pro: 

       
      Подскажите пожалуйста куда копать
  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.