buslikdrev

После установки OC 3.0 ошибка

Рекомендуемые сообщения

buslikdrev    36

После установки 3.0.0.0 такая ошибка при попытки перейти из админки в магазин, то перекидывает на страницу установки и прочтение лицензии, а там такая ошибка:
Warning: fwrite() expects parameter 2 to be string, array given in /var/www/inglsuns/data/www/demo30.virtualavto.by/system/library/session/file.php on line 48

Скрытый текст

62meD-vEq1Q.jpg

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
buslikdrev    36

Вот хитрая жопа создатель движка:
в этом файле строчки закомментировал
admin/controller/startup/sass.php
 

Скрытый текст

Было:


<?php
class ControllerStartupSass extends Controller {
	public function index() {
		$file = DIR_APPLICATION . 'view/stylesheet/bootstrap.css';

		//if (!is_file($file)) {
			include_once(DIR_SYSTEM . 'vendor/scss.inc.php');
			
			$scss = new Scssc();
			$scss->setImportPaths(DIR_APPLICATION . 'view/stylesheet/sass/');

			$output = $scss->compile('@import "_bootstrap.scss"');

			$handle = fopen($file, 'w');

			flock($handle, LOCK_EX);

			fwrite($handle, $output);

			fflush($handle);

			flock($handle, LOCK_UN);

			fclose($handle);
		//}
	}
}

Стало:


<?php
class ControllerStartupSass extends Controller {
	public function index() {
		$file = DIR_APPLICATION . 'view/stylesheet/bootstrap.css';

		if (!is_file($file)) {
			include_once(DIR_SYSTEM . 'vendor/scss.inc.php');
			
			$scss = new Scssc();
			$scss->setImportPaths(DIR_APPLICATION . 'view/stylesheet/sass/');

			$output = $scss->compile('@import "_bootstrap.scss"');

			$handle = fopen($file, 'w');

			flock($handle, LOCK_EX);

			fwrite($handle, $output);

			fflush($handle);

			flock($handle, LOCK_UN);

			fclose($handle);
		}
	}
}

 

 

 

Ошибку устранил.

Изменено пользователем buslikdrev

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
buslikdrev    36

В общем у меня что-то с кешом, не обновляется нормально, приходится чистить кэш гугл хром.
Моидификаторы установить не удаётся.

Изменено пользователем buslikdrev

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Dotrox    320
27 минут назад, buslikdrev сказал:

Вот хитрая жопа создатель движка:
в этом файле строчки закомментировал

Просто вы играетесь с версией, которая не предназначена для реального использования. Да, официально это стабильный релиз, но реально нулевые версии в ОК - это что-то среднее между альфой и бетой. Так что, если вы планируете создавать магазин на 3.0 (а не просто поиграться) - забудьте и ждите 3.1.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
buslikdrev    36
7 минут назад, Dotrox сказал:

Просто вы играетесь с версией, которая не предназначена для реального использования. Да, официально это стабильный релиз, но реально нулевые версии в ОК - это что-то среднее между альфой и бетой. Так что, если вы планируете создавать магазин на 3.0 (а не просто поиграться) - забудьте и ждите 3.1.

планирую адаптировать модули.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти


  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу