Jump to content
KoloS

При копировании товара он удаляеся

Recommended Posts

Помогает, знать бы первопричинность))) 

Share this post


Link to post
Share on other sites
Posted (edited)

Новая проблема! Стоит Экспорт товаров в ВК... при экспорте все товары удалились, модуль выдал ошибку "у товара отсутствует главное изображение"

 

Господа, тут много профи, кто то может дать внятный ответ что происходит? Проблема не единичная... Проблема в браузере или в чем???

 

при нажатии сохранить часто сохраняется две копии...

Edited by Tobolskiy

Share this post


Link to post
Share on other sites
В 03.08.2019 в 15:16, divaktolik сказал:

Вначале помогло, первый раз товар скопировался, второй раз ничего не произошло, а все последующие разы товары снова начали удаляться...

Это в хроме, а в яндексе вроде работает(хотя до этой правки тоже удаляло)

 

подтверждаю, скопировалось раз 5-6 потом снова начало удаляться...

Share this post


Link to post
Share on other sites
В 31.03.2017 в 16:05, alexstorm сказал:

 В файле admin/view/template/catalog/product_list.tpl

#6 строка

заменить:


<button type="submit" form="form-product" href="<?php echo $copy; ?>" data-toggle="tooltip" title="<?php echo $button_copy; ?>" class="btn btn-default"><i class="fa fa-copy"></i></button>

на


<button type="button" data-toggle="tooltip" title="<?php echo $button_copy; ?>" class="btn btn-default" onclick="$('#form-product').attr('action', '<?php echo $copy; ?>').submit()"><i class="fa fa-copy"></i></button>

 

Спасибо помогло)

Share this post


Link to post
Share on other sites

А в чем реально проблема, кто-нибудь в курсе? Слышал что из за последних версий браузера такая проблема.

Share this post


Link to post
Share on other sites
6 минут назад, webnet сказал:

А в чем реально проблема, кто-нибудь в курсе?

 

6 минут назад, webnet сказал:

Слышал что из за последних версий браузера такая проблема.

Зачем спрашиваете?

Share this post


Link to post
Share on other sites

А вот мне не помогло, при нажатии на кнопку "копировать" ни чего не происходит.

Версия ocStore 2.3.0.2.3 Браузер Chrome

 

Нашел решение в другом месте, заменил строчку на такую и все заработало:

<button type="button" onclick="$('#form-product').attr('action', '<?php echo $copy; ?>').submit()" data-toggle="tooltip" title="<?php echo $button_copy; ?>" class="btn btn-default"><i class="fa fa-copy"></i></button>

 

Edited by leshkakrash

Share this post


Link to post
Share on other sites
В 23.07.2019 в 20:53, Sergey36 сказал:

 

В 2.3.0.2.3 тоже замечен. Убрал.
Интересно только, как он появился) Раньше такого никогда небыло.

а как в 2.3.0.2.3  убрали?

Share this post


Link to post
Share on other sites
В 06.09.2019 в 06:57, leshkakrash сказал:

А вот мне не помогло, при нажатии на кнопку "копировать" ни чего не происходит.

Версия ocStore 2.3.0.2.3 Браузер Chrome

 

Нашел решение в другом месте, заменил строчку на такую и все заработало:


<button type="button" onclick="$('#form-product').attr('action', '<?php echo $copy; ?>').submit()" data-toggle="tooltip" title="<?php echo $button_copy; ?>" class="btn btn-default"><i class="fa fa-copy"></i></button>

 

не работает

Share this post


Link to post
Share on other sites

Приветствую. На многих наших сайтах данная проблема обострилась недели 3 назад, после обновления браузеров. Наблюдается только в Хроме и Опере, в Firefox все работает, как и прежде, ничего не удаляется. Применили решение из этой темы - в хроме и опере все становится ок, а вот в мозилле при копировании появляется 2 или даже 3 товара. Проверьте у себя кто-нибудь, плиз. Потому как если это массово, то решение проблемы такое себе.

Share this post


Link to post
Share on other sites

Снёс 100 товаров в ocStore 2.3.0.2.3, в Опере. Минус неделя работы. Где гарантия, что в Фаерфоксе такое не произойдёт потом?

Share this post


Link to post
Share on other sites

100% гарантию даже господь бог не дает

бекапы делайте регулярно

Share this post


Link to post
Share on other sites

патч бы надо по этой балячке

Share this post


Link to post
Share on other sites

Всем привет,сегодня столкнулся с аналогичной проблемой)Браузер Хром.Не появилось нормального решения проблемы данной ребята?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

On our site, cookies are used and personal data is processed to improve the user interface. To find out what and what personal data we are processing, please go to the link. If you click "I agree," it means that you understand and accept all the conditions specified in this Privacy Notice.