kolek5520

Сервер отвечает редиректом на запрос /robots.txt

Рекомендуемые сообщения

kolek5520    9

Добрый день.
на сайте используем ssl протокол
так вот в яндекс.вебмастер выдает мне что:
Робот не смог получить доступ к файлу robots.txt при последнем обращении. Из-за отсутствия параметров индексирования и инструкций в поиск могут попасть нежелательные страницы.
 Сервер отвечает редиректом на запрос /robots.txt

e510d410bcdf46a8acc091468b3fffcb.png
 
как это поправить?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
donartem    11

Попробуйте в Htaccess
<FilesMatch "robots.txt$">
RewriteEngine off
</FilesMatch>
встречал на одном из форумов решение

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
gree    0

Попробуйте в Htaccess

<FilesMatch "robots.txt$">

RewriteEngine off

</FilesMatch>

встречал на одном из форумов решение

рабочий метод, после данной доработки htacsess у меня яндекс съел robots.txt

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Lifeamove    4

@kolek5520, добрый вечер товарищ. Вы решили свою проблему? P.S. похожая проблема...

 

Кто пробовал модуль SEO Fix HTTPS 2.x отзовитесь...

 

Изменено пользователем Lifeamove

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
chukcha    1 019

Значит Я считает что robots все еще лежит по http://

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
serlen    0
В 25.07.2016 в 09:24, donartem сказал:

Попробуйте в Htaccess
<FilesMatch "robots.txt$">
RewriteEngine off
</FilesMatch>
встречал на одном из форумов решение

Спасибо помогло сразу же ))))

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Elena86    0

 

В ‎18‎.‎12‎.‎2016 в 22:54, gree сказал:

рабочий метод, после данной доработки htacsess у меня яндекс съел robots.txt

Подскажите пжт: эту строчку изменить надо:

<FilesMatch "(?i)((\.tpl|\.ini|\.log|(?<!robots)\.txt))">
 Require all denied
## For apache 2.2 and older, replace "Require all denied" with these two lines :
# Order deny,allow
# Deny from all
</FilesMatch>
 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
gree    0
4 часа назад, Elena86 сказал:

 

Подскажите пжт: эту строчку изменить надо:

<FilesMatch "(?i)((\.tpl|\.ini|\.log|(?<!robots)\.txt))">
 Require all denied
## For apache 2.2 and older, replace "Require all denied" with these two lines :
# Order deny,allow
# Deny from all
</FilesMatch>
 

нет, ту не трогайте.

найдите раздел # SEO URL Settings и в после последний в нем записи добавьте:

<FilesMatch "robots.txt$">
RewriteEngine off
</FilesMatch>

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
RazorXL    0

Ребятки а мне не помогло. Намучался уже с этим :(

 

Мой htaccess :

Спойлер

# 1.To use URL Alias you need to be running apache with mod_rewrite enabled.

# 2. In your opencart directory rename htaccess.txt to .htaccess.

# For any support issues please visit: http://www.opencart.com

Options +FollowSymlinks

# Prevent Directoy listing
Options -Indexes

# Prevent Direct Access to files
<FilesMatch "(?i)((\.tpl|\.ini|\.log|(?<!robots)\.txt))">
 Require all denied
## For apache 2.2 and older, replace "Require all denied" with these two lines :
# Order deny,allow
# Deny from all
</FilesMatch>

# SEO URL Settings
<FilesMatch "robots.txt$">
RewriteEngine off
</FilesMatch>
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/

RewriteBase /
RewriteRule ^sitemap.xml$ index.php?route=extension/feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=extension/feed/google_base [L]
RewriteRule ^system/download/(.*) index.php?route=error/not_found [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]


### Additional Settings that may need to be enabled for some servers
### Uncomment the commands by removing the # sign in front of it.
### If you get an "Internal Server Error 500" after enabling any of the following settings, restore the # as this means your host doesn't allow that.

# 1. If your cart only allows you to add one item at a time, it is possible register_globals is on. This may work to disable it:
# php_flag register_globals off

# 2. If your cart has magic quotes enabled, This may work to disable it:
# php_flag magic_quotes_gpc Off

# 3. Set max upload file size. Most hosts will limit this and not allow it to be overridden but you can try
# php_value upload_max_filesize 999M

# 4. set max post size. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value post_max_size 999M

# 5. set max time script can take. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_execution_time 200

# 6. set max time for input to be recieved. Uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_input_time 200

# 7. disable open_basedir limitations
# php_admin_value open_basedir none

### Display PHP errors 
### Uncomment the commands by removing the # sign in front of it.
# php_flag display_startup_errors on
# php_flag display_errors on
# php_flag html_errors on
# php_flag track_errors on
# php_value error_reporting "E_ALL"

AddDefaultCharset utf-8
AddType 'text/html; charset=utf-8' .html .htm .shtml

RewriteCond %{THE_REQUEST} ^[A-Z]{3,9}\ /([^/]+/)*(default|index|main)\.(html|php|htm)\ HTTP/ [NC]
RewriteRule ^(([^/]+/)*)(default|main|index)\.(html|php|htm)$ https://omega3.su/$1 [L,R=301]
RewriteCond %{QUERY_STRING} ^_route_=index.html$
RewriteRule ^(.*)$ https://omega3.su/? [R=301,L]

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти


  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу