Jump to content
Sign in to follow this  
muqpuctoqpejib

[Решено] Потерялись стили и разметка

Recommended Posts

Доброе время суток, уважаемые форумчане.

 

По неизвестной мне причине, на сайте перестали отображаться стили и html разметка контента. Почти везде. В описаниях товара, в PAV-блоге. почему это произошло, я не ведаю. Думал, запарол какой то из css файла. Но проблема оказалась в БД, как я это выяснил? Просто откатил бекап БД и все нормально, но стоит поставить новую БД, как все рушится к чертям. Помогите пожайлуста, уже все глаза "в кровь стер", сравнивая базу данных.... Может была у кого такая проблема? Откуда плясать?

 

UPD: Когда захожу в админке, править товар через CKeditor, там все нормально отображает. И работает

 

Версия жвижка 1,5,6 Open Cart.

 

 

post-705824-0-35808900-1453527123_thumb.png

post-705824-0-16748300-1453527140_thumb.png

post-705824-0-08108600-1453527561_thumb.png

Edited by muqpuctoqpejib

Share this post


Link to post
Share on other sites

Фуф, заменял поочередно каждую таблицу в БД... И наконец нашел, в чем проблема.... oc_setting. Вот больное место. Но стоит заменить лишь эту таблицу, как выходит на главной что....

 

Ошибка в типе содержимого

Страница, которую вы пытаетесь просмотреть, не может быть показана, так как она использует неверную или неподдерживаемую форму компрессии.

    Пожалуйста, свяжитесь с владельцами веб-сайта и проинформируйте их об этой проблеме.

 

Помогите решить

Share this post


Link to post
Share on other sites

Чем помочь-то? Посочувствовать?

По картинкам погадать?

Share this post


Link to post
Share on other sites

Вы только молвите, какая информация вам нужна, для совета, и все предоставлю!

Share this post


Link to post
Share on other sites

GZIP сжатие отключите.

Share this post


Link to post
Share on other sites

По идее сжатие должно отлично работать. Если не работает, значит проблема в кодировке какого-то файла. Чаще всего это файлы сторонних модулей.

Share this post


Link to post
Share on other sites

По идее сжатие должно отлично работать. Если не работает, значит проблема в кодировке какого-то файла. Чаще всего это файлы сторонних модулей.

ВЫрубил сжатие, заработало. Потом опять поставил такой же уровень, и все работало...Просто, таблица oc_setting, как я понял, перезаписалась, с верными параметрами...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

On our site, cookies are used and personal data is processed to improve the user interface. To find out what and what personal data we are processing, please go to the link. If you click "I agree," it means that you understand and accept all the conditions specified in this Privacy Notice.