Jump to content
Sign in to follow this  
XXXBOY

Ошибка VQmod"а

Recommended Posts

Доброго времени суток всем!
Заметил ошибку у себя, думал что связано с шаблоном, потом проверил на голом ocstore, там такого не наблюдал, установил VQMOD и ошибка появилась, больше ничего не вставлял  я =)
 
Сохраняю товар,  нажимаю назад и возвращаюсь обратно и опять сохраняю, и при сохранении открывается белая страница с ошибкой

2015-03-01 19:03:45 - PHP Notice:  Undefined index: option_value_id in /sitel/admin/model/catalog/product.php on line 173
2015-03-01 19:03:45 - PHP Warning:  Cannot modify header information - headers already sent by (output started at /site/admin/index.php:86) in /home/site/vqmod/vqcache/vq2-system_engine_controller.php on line 28
2015-03-01 19:03:45 - PHP Warning:  Cannot modify header information - headers already sent by (output started at /site/admin/index.php:86) in /home/site/vqmod/vqcache/vq2-system_engine_controller.php on line 29

Вот скрины двух опции что я создал. Если одну опцию удалить, то этой проблемы нет

03882f3fcb.jpg11422a59ad.jpg


 
Некоторые опции сами отключаются после этой ошибки.

 

ПРоверял на голом OCstore + VQmod, думаю у всех такая ошибки =)
 
ВОТ ВИДЕО
http://www.youtube.com/watch?v=2HVz1f3tYaA

Share this post


Link to post
Share on other sites

vqmod-2.4.1-opencart

Ocstore 1.5.5.1.2

Share this post


Link to post
Share on other sites

Никто не знает причину?:)

Share this post


Link to post
Share on other sites

хз, с таким не сталкивался..

Попробуйте через phpMyadmin сделать проверку таблиц БД на предмет ошибок

Share this post


Link to post
Share on other sites

хз, с таким не сталкивался..

Попробуйте через phpMyadmin сделать проверку таблиц БД на предмет ошибок

а по подробнее? как?

я только что еще раз проверял.

1) Скачал заново ocstore 1.5.5.1.2 - установил

2) скачал vqmod 2.4.1 - установил (после процедуры даже обновил до последнего и так проверял)

3) Создал тестовый товар

4) создал две опции  типы "флажок" и "переключатель" (выше скрин есть)

5) к тестовому товару добавил эти оба опции

6) зашел на "изменить товар" сохранил, потом вернулся назад и обратно нажал "сохранить" и БАЦ )ошибка.

Раз на чистом движке она появляется, то у всех по моему мнению должна эта ошибка появится )

Share this post


Link to post
Share on other sites

Использую ocstore 1.5.5.1.2 + vqmod 2.4.1 - сколько не кряхтел, у меня все нормально с опциями, хоть засохраняйся :-D

Ради эксперимента попробуйте на локалке при тех же условиях, что и на сайте.

 

PS: только у меня два языка доступны - рус/анг, на скринах у вас только рус - пробуйте именно на чистой версии, без удаления языков

Share this post


Link to post
Share on other sites

Проверил , заново переустановил) все равно

2015-03-02 22:13:40 - PHP Notice:  Undefined index: option_value_id in ***/admin/model/catalog/product.php on line 173
2015-03-02 22:13:40 - PHP Notice:  Undefined index: option_value_id in /***/admin/model/catalog/product.php on line 173
2015-03-02 22:13:40 - PHP Notice:  Undefined index: option_value_id in ***/admin/model/catalog/product.php on line 173

Вот именно как я описал сделайте, должна эта ошибка выйти)

чтобы две опции были у товара, если одну сделать, то этой ошибки нет, две и именно тип как я указал:-)

Share this post


Link to post
Share on other sites

До этого на сервере пробовал, сейчас в локалке - у меня на обоих работает без ошибок (ocstore 1.5.5.1.2 + vqmod 2.4.1)

Share this post


Link to post
Share on other sites

Сохраняю товар, нажимаю назад и возвращаюсь обратно и опять сохраняю, и при сохранении открывается белая страница с ошибкой

не балуйся с историей браузера.

Share this post


Link to post
Share on other sites

Да, это ошибка возникает при повторном добавлении той же самой инфы в базу. Так и переводится -- не удается изменить информацию заголовка-заголовки уже прислал. Ещё бывает такое с модулями экспорта импорта, когда неправильно настроишь. Импорт сделал, но неправильно оказалось, поверх этого ещё делаешь импорт, а движок уже не даёт наложить ту же инфу. Товары, категории и всё полностью поудаляешь в админке, тогда получается. А бывает в админке пусто, а в базе всё равно осталось. Я тогда базу вручную всю вычищал.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

On our site, cookies are used and personal data is processed to improve the user interface. To find out what and what personal data we are processing, please go to the link. If you click "I agree," it means that you understand and accept all the conditions specified in this Privacy Notice.