Jump to content
Sign in to follow this  
shuriban

[Решено] Не полный список производителей в алфавитном указателе

Recommended Posts

День добрый. Проблема такая: в стандартом ocstore 1.5.5.1 на сайте внизу страницы есть влкадка "Дополнительно",в ней есть пункт "производители" при нажатии на который идет поиск по производителю- в алфавитном указателе должны отображаться буквы всех производителей сайта. У меня в этом алфавитном указателе отображается всего одна буква и соответственно производители на эту букву. Почему не отображаются все буквы производителей в алфавитном указателе?

post-20509-0-42623700-1388919617_thumb.jpg

Share this post


Link to post
Share on other sites

скриншот раздела производителей из админки покажите.

скорее всего у вас и есть ВСЕГО ОДИН производитель.

Share this post


Link to post
Share on other sites

а они точно включены?

Share this post


Link to post
Share on other sites

в админке же нет окошка "влючить " в производителях ,ну вот для примера любой другой

post-20509-0-30895900-1389004385_thumb.jpg

post-20509-0-15940400-1389004479_thumb.jpg

Share this post


Link to post
Share on other sites

Да, действительно (у себя добавил возможность отключать производителей и уже привык к этому).

Для начала очистите кэш (system/cache).

Укажите, какие дополнения установили и (если) какие изменения проделали с товарами/производителями.

Также проверьте корректность данных о подключении к БД в конфигах (в config.php должны быть такие же, как в admin/config.php).

Share this post


Link to post
Share on other sites

Да,действительно в файлах config есть отличия,только подскажите где и что изменить. Устанавливал приложения:vqmod,import/export,youtube. И еще,подскажите как правильно чистить кэш?

post-20509-0-29361200-1389008574_thumb.jpg

Share this post


Link to post
Share on other sites

В конфигах идентичными должны быть все "DB_ данные

define('DB_...
Все остальное сейчас не важно.

>> как правильно чистить кэш?

обычным удалением всех файлов в той директории.

Share this post


Link to post
Share on other sites

Короче все попробовал : кэш почистил,в конфигах в DB_ все одинаково.Результат тот же- один производитель .

Share this post


Link to post
Share on other sites

Убедитесь, что в начале названий производителей нет пробелов.

Внимательно сравните данные выводящегося производителя с несколькими неотображающимися.

Если и это ничего не прояснит - видимо, вопрос следует решать в частном порядке.

  • +1 1

Share this post


Link to post
Share on other sites

Все решилось! Сделал следующее : в админке стер названия производителей и тут же ввел такие же имена и они начали отображаться на сайте в алфавитном указателе.Скорее всего это было из-за того,что ранее я вводил названия производителя по автозаполнению (т.е. при вводе первой буквы комп предлагал мне ввести готовое имя - видать запомнил их при создании сайта еще до хостинга). Хочу поблагодарить поддержку за грамотную помощь в решении этой проблемы,спасибо!

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

On our site, cookies are used and personal data is processed to improve the user interface. To find out what and what personal data we are processing, please go to the link. If you click "I agree," it means that you understand and accept all the conditions specified in this Privacy Notice.