Перейти к содержанию
pika4u

возникла ошибка в system/library/image.php

Рекомендуемые сообщения

- сегодня. после переезде на другой домен, и соответственно в другую папку, теперь появилась ошибка {PHP Notice: Undefined index: bits in /var/data/www/newdomenname/system/library/image.php on line 16}. правда она вылазила всего 2раза за последние 2часа но все равно хотелось бы ее больше не встречать.

а и немножко туговато работать стал где то на ~100-150мс.

можно как то наладить все?

- забыл версия ocStore v0.1.9

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

- сегодня. после переезде на другой домен, и соответственно в другую папку, теперь появилась ошибка {PHP Notice: Undefined index: bits in /var/data/www/newdomenname/system/library/image.php on line 16}.

И на другой сервер?

"For some image types, the presence of channels and bits values can be a bit confusing. As an example, GIF always uses 3 channels per pixel, but the number of bits per pixel cannot be calculated for an animated GIF with a global color table."

Картинки точно не менялись? Может вы используете какие-то анимированные гифки а раньше просто не замечали этой проблемы?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

нет хостер тот же. нет картинки не менялись. ошибки раньше не было лог старый есть, такой ошибки ранее не было. да gif'ки есть в категориях, но они отображаются нормально.

и гифки не анимированные

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Там код простейший. Единственное что возможно - что функция PHP не возвращает в массиве значения bits. Я вижу только две возможные причины - изменение версии PHP или картинки для которых эта функция не возвращает данного значения (либо битый файл картинки).

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

вобще с картинками все тип топ. хотя может из за картинки статистики? она я ее не изменил параметры ее она работает но не генирирует цыферки)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

вобще с картинками все тип топ. хотя может из за картинки статистики? она я ее не изменил параметры ее она работает но не генирирует цыферки)

Проверьте. Почистите лог, сходите на страницу статистики и посмотрите лог.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

я пробывал. пака больше нет такой ошибки. надеюсь и не будет больше)

серавно спасибо)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.