Перейти к содержанию
remix8080

[Решено] SEO URL и локальный сервер

Рекомендуемые сообщения

На локалке использую XAMPP. Так вот, при включенном SEO-url, когда кликнуть на категорию открывает страницу http://127.0.0.1/xampp/ вместо http://127.0.0.1/mysite/category

На хостинге все нормально, а на локалке вот такое...

В чем проблема?

П.С. Хотя и не очень критично.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

в .htaccess

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

в .htaccess

У меня про SEO в .htaccess такое:

# SEO URL Settings
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)\?*$ index.php?_route_=$1 [L,QSA]

А у Вас? :-)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

http://127.0.0.1/mysite/category'>http://127.0.0.1/mysite/category == RewriteBase /mysite/

RewriteBase / == http://127.0.0.1/

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Возможно у человека на сервере не включен mod_rewrite ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Малость подзабыл про этот свой вопрос т.к. пока не актуален...

Senty, а где включается mod_rewrite? Что-то не могу найти :-(

UPD. Нашел, где включается. Вопрос снят.

Изменено пользователем remix8080

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Малость подзабыл про этот свой вопрос т.к. пока не актуален...

Senty, а где включается mod_rewrite? Что-то не могу найти :-(

UPD. Нашел, где включается. Вопрос снят.

На будущее, касается всех, делитесь пожалуйста тем, как Вы решили свою проблему, т.к. она может возникнуть не только у Вас!

На своё локальном хостинге Apache требует под загрузки модуля rewrite.

Включить модуль Apache2 mod_rewrite можно следующим образом:

1. Перейти в директорию с модулями, которые Apache2 уже подгружает

cd /etc/apache2/mods-enabled
2. Создать символическую ссылку, которая будет ссылаться на модуль, который необходимо подгружать, ярлык:

sudo ln -s /etc/apache2/mods-available/rewrite.load
3. Перезагрузить Apache2

sudo /etc/init.d/apache2 graceful
или

sudo /etc/init.d/apache2 restart

Это для сервера под Debian. Для других систем может отличаться.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.