Jump to content
sitecreator

Не обновляются модификаторы, ничего не записывается в лог модификаторов.встречали подобное?

Recommended Posts

Версия ocStore 3.0.2.0

 

Обновление модификаторов - дело привычное.

выглядит это так (исправный вариант) :

 

sitecreator_ru_OdS0j7P63n.gif

 

 

 

Неисправный вариант:

 

tQjUB5l.gif

 

 

 

Файл лога остается нулевым по размеру, меняется лишь время его обновления, и то не всегда.

Включение/выключение и обновление модификаторов не приводит к результату.

Но иногда срабатывает.

Share this post


Link to post
Share on other sites

Кеш статики html, php

Share this post


Link to post
Share on other sites

посмотри 301

Share this post


Link to post
Share on other sites

Похоже, что где-то что-то, действительно, кешируется жестким образом.

Само собой заработало.

 

Ошибок в консоли браузера не было.

Надо будет еще понаблюдать если повторится.

 

Share this post


Link to post
Share on other sites

js на стороне сервера кэшируется

встречал недавно

Share this post


Link to post
Share on other sites

У меня была такая ситуация, я уже все перепробовл, везде смотрел. На тройке. Метод максимально топорный но он в тот момент был полностью оправдан. Я в url добавлял на каждую страницу приставку рандом и работало все нормально. Это что-то кеширует админку 100%

Share this post


Link to post
Share on other sites

неужели не понятно что?

В этом плане я говорю - ну что? дооптимизировались?

Share this post


Link to post
Share on other sites
1 час назад, Exploits сказал:

Это что-то кеширует админку 100%

 

точно.

причем такой гадости не наблюдал никогда на родном опенкарт.

 

1 час назад, deim сказал:

js на стороне сервера кэшируется

 

там где-то глубже причина. хоть и это тоже может быть в добавок ко всему.  Мне тоже показалось, что js тоже влияет как-то.

сам запрос на выполнение модификаторов отправлялся и что-то выполнялось.  иначе бы лог файл не менял бы время последнего обновления, хоть и оставался пустым при этом.

Раз лог файл обновлял свое время, значит, в него просто писалась пустая строка, т.е. php отрабатывал.

 

Я подозреваю, что кто-то заложил, вероятно, какой-то механизм, который не делает обновление модификаторов если считает, что их не нужно обновлять.

жесткой логики такого поведения я не смог проследить.

Share this post


Link to post
Share on other sites

НЕТ там ничего!!! Не ищите черного кота
Смотрите ответы сервера..

Share this post


Link to post
Share on other sites
19 минут назад, sitecreator сказал:

 

точно.

причем такой гадости не наблюдал никогда на родном опенкарт.

 

 

там где-то глубже причина. хоть и это тоже может быть в добавок ко всему.  Мне тоже показалось, что js тоже влияет как-то.

сам запрос на выполнение модификаторов отправлялся и что-то выполнялось.  иначе бы лог файл не менял бы время последнего обновления, хоть и оставался пустым при этом.

Раз лог файл обновлял свое время, значит, в него просто писалась пустая строка, т.е. php отрабатывал.

 

Я подозреваю, что кто-то заложил, вероятно, какой-то механизм, который не делает обновление модификаторов если считает, что их не нужно обновлять.

жесткой логики такого поведения я не смог проследить.

Много раз с таким сталкивался

В htaccess или в настройках сервера включено кеширование статики html, php и т п

  • +1 1

Share this post


Link to post
Share on other sites
38 минут назад, markimax сказал:

Много раз с таким сталкивался

В htaccess или в настройках сервера включено кеширование статики html, php и т п

Вот!!!

Share this post


Link to post
Share on other sites
8 часов назад, markimax сказал:

В htaccess или в настройках сервера включено кеширование статики html, php и т п

 

да, это может объяснить магию.

 

Сегодня снова столкнулся с магией кеширования. на другом сайте. движок тот же ocstore 3

 

поправил header.twig.

Без проблем увидел изменения в конечной странице HTML.

поправил footer.twig.

А изменений никаких!

 

Чищу все мыслимые кеши, обновляю модификаторы. Ноль изменений в HTML!

При этом если переименовать footer.twig в _footer.twig, то изменения отображаются в HTML, т.е. низа страницы нет как и положено.

При этом даже в кеше модификаторов footer.twig в правильном виде отображается.

Где же кешируется?

 

Что за магия не к месту?

Share this post


Link to post
Share on other sites
1 час назад, sitecreator сказал:

При этом если переименовать footer.twig в _footer.twig, то изменения отображаются в HTML, т.е. низа страницы нет как и положено.

При этом даже в кеше модификаторов footer.twig в правильном виде отображается.

Где же кешируется?

проверить наличие исправлений для него в Редакторе тем

если есть - причина в этом

 

Share this post


Link to post
Share on other sites

Да, может быть еще в редакторе тем в админке - зло как по мне лютое. Всегда тоже все перерываю а потом вспоминаю за этот редактор а там чуть ли не все файлы отредактированы и модификатор с ними не работает. Да по сути тогда с теми файлами вообще ничего не работает

Share this post


Link to post
Share on other sites

@AlexDW , @Exploits у меня еще такой прикол:

 

kRUP3Pa.jpg

 

 

используется якобы шаблон по-умолчанию. и другого выбора нет.

но на самом деле используется отдельный шаблон - не заказной, а вполне серийный от одного из авторов форума. Не знаю, то ли разработчик шаблона так намудрил, то ли сам заказчик.

 

И смешное дело в том, что редактор тем в админке предлагает мне отредактировать файлы дефолтного шаблона, не ведая, что работают файлы иного шаблона.

 

13 минут назад, Exploits сказал:

в редакторе тем в админке - зло как по мне лютое

 

согласен. дурь полнейшая. Все, что делается для облегчения задач ламерам - это в итоге проблема для специалиста.

Share this post


Link to post
Share on other sites

Боюсь, что не там смотришь

Расширения - темы

Share this post


Link to post
Share on other sites
11 минут назад, chukcha сказал:

Расширения - темы

 

это само собой.

но это для настройки темы.

 

но тему же еще и выбрать нужно сперва.

 

ZUBwThp.jpg

 

для чего то же выбор в настройках магазина сделан?

Share this post


Link to post
Share on other sites
47 минут назад, sitecreator сказал:

но тему же еще и выбрать нужно сперва.

ДА, ты выбираешь тему

$this->config->get('config_theme')
Затем
$theme = $this->config->get('theme_default_directory');

 

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

On our site, cookies are used and personal data is processed to improve the user interface. To find out what and what personal data we are processing, please go to the link. If you click "I agree," it means that you understand and accept all the conditions specified in this Privacy Notice.