Перейти к содержанию
eviltwin

Фото товаров после заливки через ftp (проблема)

Рекомендуемые сообщения

Доброго времени суток!

Перенес магазин с одного сервера на другой, все норм.

Залил по фтп несколько тысяч фотографий товаров рассортированных по папкам.

Захожу в админку, добавляю товар. Пытаюсь выставить фото товаров как обычно из тех каталогов.

Захожу в нужный каталог и вместо превью вижу пустую картинку, сами названия фоток там есть.

Не ставятся нихрена. Права поставил уже на все подкаталоги 777.

Фотки дежат в images/data...

Что такое может быть?

Те что добавлял через менеджер фоток норм открываются, а что лил через ftp нифига.

Хелп уважаемые, очень надо вылечить сею проблему.

Заранее спасибо за советы :)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Доброго времени суток!

Перенес магазин с одного сервера на другой, все норм.

Залил по фтп несколько тысяч фотографий товаров рассортированных по папкам.

Захожу в админку, добавляю товар. Пытаюсь выставить фото товаров как обычно из тех каталогов.

Захожу в нужный каталог и вместо превью вижу пустую картинку, сами названия фоток там есть.

Не ставятся нихрена. Права поставил уже на все подкаталоги 777.

Фотки дежат в images/data...

Что такое может быть?

Те что добавлял через менеджер фоток норм открываются, а что лил через ftp нифига.

Хелп уважаемые, очень надо вылечить сею проблему.

Заранее спасибо за советы :)

сам сталкивался с такой проблемой, уже спрашивал у форумчан, решения не нашел, закачивал все через админку

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

А если попробывать сделать бэкап , после установки на другой сервер залить по фтп в нужную папку все картинки и воспользоваться бэкапом с предыдущего магазина,тот же результат?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

У меня на другом хосте почти небыло товаров, вот решил залить пару тысяч. Базы все восстановил, все демо товары, что создавал тоже норм. Залил сразу подготовленные фотки в папку images/data дабы потмо не мудиться с их заливкой, ибо на каждый товар в среднем по 10 фоток. Права прописал на папки полные. Я так подразумеваю весь косяк в кешировании фоток. В папке cache... Может есть решение какое? Модуль чтоли который закеширует все фотки? Мне кажется из-за этого нифига не видно. Народ хелп!

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Народ ну помогите же кто-нибудь...

Как закешировать все фотки разом?

А вообще возможно ли отображение фотографий товаров без использования кэша?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

На image/cache/data и вложенные папки точно 777 права? Перепроверь.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Да. Права правильно проставлены везде...

Сам задолбался уже....

Нет резона столько фот грузить через стандартный браузер опенкарта...

Я так понимаю нужно создать кэш картинок....

Может есть скрипт какой чтобы это сделать или софт?....

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Такая же фигня на стандартном модуле...

Нужно создать кэш картинки по принцу /image/cache/data/директори/файл-100x100.jpg

можно теже картинки туда засунуть, только грузица долго будут...

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Всем спасибо большое за советы!

Вопрос решился.

Модератора прошу закрыть тему.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Всем спасибо большое за советы!

Вопрос решился.

Модератора прошу закрыть тему.

Отпишитесь о решении, может еще кому будет полезно.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Причём превьюшки прекрасно генерируются по дефолтному пути 0:/public_html/site.ru/image/cache/data/ а движок пытается их брать в папке 0:/public_html/site.ru/cache/data/ скопировав куда сгегерированные превьюшки всё прекрасно работает. Но чем мог быть спровоцирован такой сбой не понятно, видимо надо переустанавливать движок с нуля на новом месте... плохо.. с другими СМС таких проблем ещё не возникало.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Всё, разобрался, видимо там ещё в БД какие-то правки вносятся. Посему делаем как положено:

1. На тестовом сайте (том с которого надо перенести данные) заходим в меню "Система\резервные копии" , жмём "бэкап"

2. Копируем все файлы тестового домена на домен где сайт будет располагаться постоянно

3. Поверх скопированных файлов распаковываем дистриб магазина той же версии

4. Устанавливаем магазин, используя при этом новую БД

5. Заходим в меню "Система\резервные копии" указываем путь к бэкапу, жмём "восстановить"

У меня теперь всё работает!

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Снес все нафиг, поставил по новой магаз, базу восстановил, подключил нужные модули. Косяк видать был в стороннем модуле изображений. Теперь все работает норм. Всем спасибо за ответы!

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.