Jump to content
garrip91

Хочу убрать главный логотип (изображение-ссылка, которое расположено слева от строки поиска) В OCSTORE ВЕРСИИ 3.0.2.0

Recommended Posts

Здравствуйте, дорогие форумчане!

 

Делаю сайтик по продаже рыболовных принадлежностей.

 

Мне необходимо убрать из пользовательской среды (то есть, со всех страниц, которые может посетить пользователь) главный логотип-изображение "ocStore", что находится слева от строки поиска, и запись снизу-слева "Работает на ocStore
Ваш магазин © 2019".

 

ВАЖНЫЙ МОМЕНТ: Рекомендаций о том, как всё вышеуказанное можно убрать, в интернете пруд пруди, но ни один из них мне не помог к сожалению :-(

Я ПОЛАГАЮ, ЧТО ДЕЛО ЗДЕСЬ ИМЕННО В ВЕРСИИ CMS (у меня "ocStore" версии "3.0.2.0")!!!

Share this post


Link to post
Share on other sites

Чистим кэш, обновляем модификаторы, и в браузере на странице нажимаем CTRL+F5.

 

(Если все правильно сделали)

Share this post


Link to post
Share on other sites

А почему убрать, а не заменить на другой?

Share this post


Link to post
Share on other sites
2 часа назад, SunnRi сказал:

Чистим кэш, обновляем модификаторы, и в браузере на странице нажимаем CTRL+F5.

 

(Если все правильно сделали)

Что значит "обновляем модификаторы" и как это правильно сделать? Я здесь новичок, извините :((( 

Share this post


Link to post
Share on other sites
1 час назад, SiteMix сказал:

А почему убрать, а не заменить на другой?

Ну нижнюю запись можно и заменить :-) Ну так, как это сделать?

Share this post


Link to post
Share on other sites

Я как раз логотип имел в виду. Не очень представляю сайт без логотипа.

 

Надпись меняется в файле локализации и если вы читали рекомендации как её убрать, то должны были об этом прочитать.

 

Кстати, поскольку вы только начинаете делать сайт рекомендую пересмотреть выбор версии в пользу 2.3. Избавите себя от некоторых заморочек.

Share this post


Link to post
Share on other sites

Просмотр кода логотипа показывает мне следующий фрагмент кода разметки:

    " <img src="http://localhost/www/fishing_equipment/image/catalog/opencart-logo.png" title="Ваш магазин" alt="Ваш магазин" class="img-responsive"> " (без кавычек)

 

Почему в директориях CMS отсутствует файл разметки, содержащий вышеуказанный фрагмент кода ???

МОЯ ПРОБЛЕМА.jpg

Share this post


Link to post
Share on other sites
41 минуту назад, garrip91 сказал:

Почему в директориях CMS отсутствует файл разметки, содержащий вышеуказанный фрагмент кода ???

Файл header.twig

Но в нём нет полного пути к файлу, т.к. логотип устанавливается в настройках магазина. Ищите по файлу "logo"? а дальше разберётесь.

Share this post


Link to post
Share on other sites
Posted (edited)
1 час назад, SiteMix сказал:

Файл header.twig

Но в нём нет полного пути к файлу, т.к. логотип устанавливается в настройках магазина. Ищите по файлу "logo"? а дальше разберётесь.

Я в файле "header.twig" убрал фрагмент кода " <meta property="og:image" content="{{ logo }}" /> " (без кавычек) и фрагмент (точнее, во 2-м случае уже будет БЛОК) кода

" <div id="logo">
          {% if logo %}
            {% if home == og_url %}
              <img src="{{ logo }}" title="{{ name }}" alt="{{ name }}" class="img-responsive" />
            {% else %}
              <a href="{{ home }}"><img src="{{ logo }}" title="{{ name }}" alt="{{ name }}" class="img-responsive" /></a>
            {% endif %}
          {% else %}
            <h1><a href="{{ home }}">{{ name }}</a></h1>
          {% endif %}
  </div> " (также без кавычек).

 

В файле "footer.twig" убрал фрагмент кода " <p>{{ powered }}</p> " (также без кавычек).

 

ПОСЛЕ ВСЕГО ВЫШЕИЗЛОЖЕННОГО Я ТАКЖЕ ПОЧИСТИЛ И CMS-КЭШ И КЭШ БРАУЗЕРА!!!

 

Результата - 0! :(

Edited by garrip91
Дополнение

Share this post


Link to post
Share on other sites

Кэш модификаторов.

Share this post


Link to post
Share on other sites
14 часов назад, SiteMix сказал:

Кэш модификаторов.

И кэш модификаторов я тоже почистил :-(

Share this post


Link to post
Share on other sites

 

17 часов назад, garrip91 сказал:

Я в файле "header.twig" убрал фрагмент кода

Уточню - правка в файле делалась через FTP или в редакторе который в админке? Если второе, то причина может быть в этом.

Share this post


Link to post
Share on other sites
29 минут назад, SiteMix сказал:

 

Уточню - правка в файле делалась через FTP или в редакторе который в админке? Если второе, то причина может быть в этом.

Возможно, вся моя проблема именно в этом...

Вы не могли бы скинуть мне ссылку на подробную инструкцию как все эти чудеса провернуть именно через FTP?

Share this post


Link to post
Share on other sites

НАРОД, ПРИНОШУ ВСЕМ СВОИ ИЗВИНЕНИЯ! С ВЫШЕУКАЗАННОЙ ПРОБЛЕМОЙ Я СПРАВИЛСЯ САМОСТОЯТЕЛЬНО!!!

 

Там просто нужно было на странице "Панель состояния" нажать на кнопку в виде гаечки (что под кнопкой "Выход") и далее, в появившемся окне, нажать на кнопку обновления напротив "Весь кэш" (почему-то это единственно возможный способ решения подобной проблемы... Скорее всего, это всё из-за того, что версия CMS у меня последняя стоит) :-)

 

ВСЕМ СПАСИБО ЗА ОТЗЫВЧИВОСТЬ!!! ;-)

Share this post


Link to post
Share on other sites
30 минут назад, garrip91 сказал:

Там просто нужно было на странице "Панель состояния" нажать на кнопку в виде гаечки (что под кнопкой "Выход") и далее, в появившемся окне, нажать на кнопку обновления напротив "Весь кэш"

Интересно, а что тогда имелось в виду под этим?:

19 часов назад, garrip91 сказал:

ПОСЛЕ ВСЕГО ВЫШЕИЗЛОЖЕННОГО Я ТАКЖЕ ПОЧИСТИЛ И CMS-КЭШ

 

Share this post


Link to post
Share on other sites
33 минуты назад, garrip91 сказал:

Скорее всего, это всё из-за того, что версия CMS у меня последняя стоит)

Не зря я написал:

22 часа назад, SiteMix сказал:

Кстати, поскольку вы только начинаете делать сайт рекомендую пересмотреть выбор версии в пользу 2.3. Избавите себя от некоторых заморочек.

Упомянутая, только одна из...

Share this post


Link to post
Share on other sites
2 часа назад, SiteMix сказал:

Интересно, а что тогда имелось в виду под этим?:

 

Просто я, видимо, сначала не оттуда чистил этот кэш. Я правильно это делается именно оттуда!!!

Share this post


Link to post
Share on other sites
1 час назад, garrip91 сказал:

Просто я, видимо, сначала не оттуда чистил этот кэш. А правильно это делается именно оттуда!!!

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

On our site, cookies are used and personal data is processed to improve the user interface. To find out what and what personal data we are processing, please go to the link. If you click "I agree," it means that you understand and accept all the conditions specified in this Privacy Notice.