Jump to content
Sign in to follow this  
Horsa

1.5.5.1.2 в прошлом или ещё можно юзать?

Recommended Posts

Привет!) Поставила 1.5.5.1.2 на хостинг (т.к. знаю только его и сайт пилила на локалке под него), но на хостинге выдаёт кучу ошибок. Как я поняла, дело в MSQL или ещё с чем, так и не смогла разобраться. Ребят, кто может подсказать и разобраться с проблемой? 

 

Ошибки:


Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /var/www/u0706045/data/www/......../system/database/mysql.php on line 6
Warning: session_start(): Cannot send session cookie - headers already sent by (output started at /var/www/u0706045/data/www/.........../system/database/mysql.php:6) in /var/www/u0706045/data/www/......./system/library/session.php on line 11Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /var/www/u0706045/data/www/......./system/database/mysql.php:6) in /var/www/u0706045/data/www/........./system/library/session.php on line 11Warning: Cannot modify header information - headers already sent by (output started at /var/www/u0706045/data/www/........../system/database/mysql.php:6) in /var/www/u0706045/data/www/............./index.php on line 176Warning: Cannot modify header information - headers already sent by (output started at /var/www/u0706045/data/www/......./system/database/mysql.php:6) in /var/www/u0706045/data/www/........./system/library/currency.php on line 45

 

 

 

Пыталась переустанавливать, но после установки каждый раз выдаёт эти ошибки:

Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /var/www/u0706045/data/www/......./system/database/mysql.php on line 6

Warning: Cannot modify header information - headers already sent by (output started at /var/www/u0706045/data/www/....../system/database/mysql.php:6) in /var/www/u0706045/data/www/......./system/engine/controller.php on line 28

Warning: Cannot modify header information - headers already sent by (output started at /var/www/u0706045/data/www/.......system/database/mysql.php:6) in /var/www/u0706045/data/www/......./system/engine/controller.php on line 29

 

 

**** Не прочитала правила форума, поэтому затёрла адрес сайта

Edited by Horsa

Share this post


Link to post
Share on other sites

отключите вывод ошибок, а лучше еще и смените версию php на 5.4 а лучше смените mysql на mysqlz или как там его.

первое самое простое, последнее самое сложное, но более правильное

Share this post


Link to post
Share on other sites

В прошлом, но можно юзать

 

Share this post


Link to post
Share on other sites

mysqlz скачала, но не знаю как он ставится :( 
Отключением ошибок вряд ли что-то исправится, потому что пыталась зайти в админку, не заходит, выкидывает на белый экран

 

Хостеры ничем не помогают, отсылают тупо к разработчику 

Edited by Horsa

Share this post


Link to post
Share on other sites
14 минут назад, Horsa сказал:

mysqlz скачала, но не знаю как он ставится :( 
Отключением ошибок вряд ли что-то исправится, потому что пыталась зайти в админку, не заходит, выкидывает на белый экран

 

Хостеры ничем не помогают, отсылают тупо к разработчику 

а чем обусловлен выбор данной версии?

Share this post


Link to post
Share on other sites
Цитата

а чем обусловлен выбор данной версии?

Я когда-то делала сайты на этом движке, привыкла к нему (удобный очень, хорошо знаю его), а потом забросила. Сейчас нужен был сайтец, скачала и запилила сайт как мне надо, но при установке наткнулась на непонимание)))) 2 - 3 движок не знаю совсем, и времени разбираться нет, честно, не хочется по-новой всё делать 

Share this post


Link to post
Share on other sites
10 минут назад, Horsa сказал:

Я когда-то делала сайты на этом движке, привыкла к нему (удобный очень, хорошо знаю его), а потом забросила. Сейчас нужен был сайтец, скачала и запилила сайт как мне надо, но при установке наткнулась на непонимание)))) 2 - 3 движок не знаю совсем, и времени разбираться нет, честно, не хочется по-новой всё делать 

ставьте 2.3 под него и модулей больше, и информации, а на тему разбираться, если у вас уже есть опыт с 1.5, то думаю 2.3 быстро поймете, в крайнем случае тут на форуме без проблем помогут

Edited by Pavel666

Share this post


Link to post
Share on other sites
Цитата

ставьте 2.3 под него и модулей больше, и информации, а на тему разбираться, если у вас уже есть опыт с 1.5, то думаю 2.3 быстрой поймете, в крайнем случае тут на форуме без проблем помогут

 

Я конечно сейчас на локалку поставлю 2.3, посмотрю что получится, но всё же хотелось бы 1.5 реанимировать. Спасибо

 

Edited by Horsa

Share this post


Link to post
Share on other sites
4 часа назад, Horsa сказал:

**** Не прочитала правила форума, поэтому затёрла адрес сайта

 

вы их неправильно поняли.

впрочем, они настолько "удачно" составлены, что это немудрено.

ссылки можно и нужно давать когда хотите получить предметную помощь.

 

но в вашем случае, действительно, нужно использовать mysqli/

Если движок 1.5 еще оправдано использовать когда есть кастомные разработки под него, то вот оправдания использования mysql не может быть. Это слишком тормозной вариант.

Share this post


Link to post
Share on other sites
23 часа назад, Horsa сказал:

Я когда-то делала сайты на этом движке, привыкла к нему (удобный очень, хорошо знаю его), а потом забросила. Сейчас нужен был сайтец, скачала и запилила сайт как мне надо, но при установке наткнулась на непонимание)))) 2 - 3 движок не знаю совсем, и времени разбираться нет, честно, не хочется по-новой всё делать 

 

Да ну, вы не представляете, как удобен Вордпресс. Лучше на него переходите, чем в этом мамонте копаться :grin:

Share this post


Link to post
Share on other sites
6 минут назад, Ep1c сказал:

Да ну, вы не представляете, как удобен Вордпресс. Лучше на него переходите, чем в этом мамонте копаться

это точно. ВП дырявое ржавое ведро с песочком для ковыряния детишек, а ОС для взрослых с мозгом, детям тут не место, странно @Ep1c что вы тут забыли ?

Share this post


Link to post
Share on other sites
13 минут назад, Ep1c сказал:

чем в этом мамонте копаться

 

Лучше в мамонте копаться, чем в дерьме.

  • +1 1

Share this post


Link to post
Share on other sites

С большим опозданием, но отписываюсь по теме. В общем решила проблему в тот же день, установив mysqliz в (/system/database/

В конфигах внесла коррективы в (admin/config.php) и в корневой папке (config.php)


БЫЛО: define('DB_DRIVER', 'mysql');
СТАЛО: define('DB_DRIVER', 'mysqliz');

 

Всем неравнодушным, хочу сказать большое спасибо за поддержку!)

mysqliz.zip

Share this post


Link to post
Share on other sites

Опенкарт очень хороший движок, мне очень нравится, но в нём надо разбираться, моих знаний и сил (или терпения), к сожалению, не хватило на вторую и третью версию, поэтому всё-таки поставила 1.5.5.1.2 (т.к. был под него заточен сайт), надеюсь, в будущем осилю что-нибудь повыше)

Edited by Horsa

Share this post


Link to post
Share on other sites
В 29.04.2019 в 22:54, Horsa сказал:

С большим опозданием, но отписываюсь по теме. В общем решила проблему в тот же день, установив mysqliz в (/system/database/

В конфигах внесла коррективы в (admin/config.php) и в корневой папке (config.php)


БЫЛО: define('DB_DRIVER', 'mysql');
СТАЛО: define('DB_DRIVER', 'mysqliz');

 

Всем неравнодушным, хочу сказать большое спасибо за поддержку!)

mysqliz.zip 1 \u043a\u0411 · 1 download

Спасибо сам сегодня правил

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By Gilbert
      Написал в поддержку модуля, но никак не дождусь ответа, быть может вы поможете? При импорте товаров через модуль export/import выходят 3 непонятные ошибки:
      2020-06-16 8:44:35 - Export/Import: Отсутствуют product_ids в файле 'Products'!
      2020-06-16 8:44:35 - Export/Import: Отсутствуют product_ids в файле 'Specials'!
      2020-06-16 8:44:35 - Export/Import: Отсутствуют customer_groups в файле 'Specials'!
      Не могу понять что это такое, в файле excel нет колонки product_ids, и не пойму, почему обязательно наличие customer_groups, раньше с этим проблем не было. Как исправить?
    • By MarkTaison
      Поставил версию ocStore 2.1.0.2, установил модуль маркетплейс но из-за этого вылетает очень много ошибок. Можно ли как то решить данную проблему?
    • By magdi2000li7
      Добрый день, на днях перенес сайт abrom.ru с виртуального хостинга на vds и тут посыпались проблемки
       
      Сейчас вроде сайт работает, но очень медленно грузится, очень странно, такого не было.
       
      Сколько будет стоить приведение к нормальному(прошлому) состоянию? На виртуальном хостинге все еще лежит нормальная версия сайта.
       
       
    • By LILIA93
      После обновления шаблона сайта OPENCART.PRO, Версия 2.3.0.2.5 возникли некоторые проблемы:
      - zoom фото товара при наведении исчез;
      - когда заливаем фото в хорошем качестве, оно сжимается и размазывается, на сайте выглядит некрасиво;
      - доп табы "как использовать" и "состав"0 есть в админке, но не видны на сайте.
      Подскажите, как устранить данные проблемы? 
    • By Gilbert
      http://tovarnadom-sharan.ru/ в консоли есть 2 ошибки, как их исправить? Помогите, пожалуйста.
       

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

On our site, cookies are used and personal data is processed to improve the user interface. To find out what and what personal data we are processing, please go to the link. If you click "I agree," it means that you understand and accept all the conditions specified in this Privacy Notice.