Jump to content

Recommended Posts

Перевёл сайт на https, но из за одной картинки, она на http, не хочет показывать замочек зелёный, типа надёжный. Картинка - гифка, Ajaxsearchloader.gif. Сайт irmi.ua. Кто подскажет где исправить? Название может чуть не правильное, пишу с телефона, не могу посмотреть точно.

Share this post


Link to post
Share on other sites
Posted (edited)
1 час назад, AlexLSL сказал:

из за одной картинки

это не из за 1 картинки, у вас 71 ссылка с http:

что то не доделали)

 

проверьте конфиги и htaccess

Edited by zlob
  • +1 1

Share this post


Link to post
Share on other sites

Спасибо, действительно дело в конфигах, добавил везде в конце s (https) и заработало.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By nic2450
      Opencart 2.3 

      1) SSL сертификат получил у хостера (бесплатный Let's Encrypt )

      2) в .htaccess прописал :
      RewriteEngine On  RewriteCond %{HTTP:X-Forwarded-Proto} !https RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L] 3) в config.php 
      HTTPS define('HTTPS_SERVER', 'https://site.ru/') 4) в admin/config.php
      HTTP  define('HTTP_SERVER', 'https://site.ru/admin/'); define('HTTP_CATALOG', 'https://site.ru/'); HTTPS define('HTTPS_SERVER', 'https://site.ru/admin/'); define('HTTPS_CATALOG', 'https://site.ru/');
      5)в админке сайта настройки-сервер нажал "использовать SSL"

      В итоге когда ввожу https:// адрес сайта , то все ок - открывается главная страница, и в опере и в хроме " замочек" есть. Но переход на любую страницу - и уже вместо замочка надпись "ненадежный", в том числе если возвращаюсь на главную страницу обратно. 

      Сайт новый, с seo ничего не делал еще, если это имеет какое то отношение к делу 

      Что еще требуется чтобы https заработал ?
    • By Corso
      Требуется перевести сайт на https с сохранением корректной работы всех модулей и существующей верстки. 
      Пробовал сам, но вся верстка плывет.
      http://four-in-hand.ru/
       
       
    • By antixreest
      https://promkomm.ru/image/cache/catalog/revolution/payment/visa-50x30.png вот что получилось и не дам ума что сделал не так,так как не я переводил сайт сейчас хочу с нуля перевести чтоб исправить ошибки предшественника.Буду благодарен за любую информацию желательно детальную и для ребенка В заранее спасибо. 
    • By Loys
      (174) if (!function_exists('curl_exec')) $data['error_warning'] .= $this->language->get('curl_disable'); (175) (176) $data['breadcrumbs'] = array(); (177) $data['breadcrumbs'][] = array( (178) 'text' => $this->language->get('text_home'), (179) 'href' => $this->url->link('common/dashboard', 'user_token=' . $this->session->data['user_token'], 'SSL') (180) ); (181) $data['breadcrumbs'][] = array( (182) 'text' => $this->language->get('text_module'), (183) 'href' => $this->url->link('extension/module', 'user_token=' . $this->session->data['user_token'], 'SSL') (184) ); (185) $data['breadcrumbs'][] = array( (186) 'text' => $this->language->get('heading_title'), (187) 'href' => $this->url->link('module/category', 'user_token=' . $this->session->data['user_token'], 'SSL') (188) ); (189) (190) $data['button_save'] = $this->language->get('button_save'); (190) $data['button_cancel'] = $this->language->get('button_cancel'); (191) (193) $data['action'] = $this->url->link('extension/module/convead', 'user_token=' . $this->session->data['user_token'], 'SSL'); (194) $data['cancel'] = $this->url->link('extension/module', 'user_token=' . $this->session->data['user_token'], 'SSL'); Добрый день! После установки модуля, столкнулся со следующей проблемой. Не могу его активировать, так как на странице с модулем вылезает следующая ошибка:
      Notice: Undefined index: user_token in /home/b/***/public_html/admin/controller/extension/module/convead.php on line 179Notice: Undefined index: user_token in /home/b/***/public_html/admin/controller/extension/module/convead.php on line 183Notice: Undefined index: user_token in /home/b/***/public_html/admin/controller/extension/module/convead.php on line 187Notice: Undefined index: user_token in /home/b/***/public_html/admin/controller/extension/module/convead.php on line 193Notice: Undefined index: user_token in /home/b/***/public_html/admin/controller/extension/module/convead.php on line 194 Проблема с токене, как только произвожу какое-либо действие в модуле, например его активацию, сразу вылетаю из админке и настройки не сохраняются.
      Версия движка: ocStore 2.3.0.2.3
      Модуль для 2.3.Х
       
      Часть кода прилагаю выше.
      P.S. в конфиге админки всё прописано корректно.
       
      Спасибо за ответы!
  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

On our site, cookies are used and personal data is processed to improve the user interface. To find out what and what personal data we are processing, please go to the link. If you click "I agree," it means that you understand and accept all the conditions specified in this Privacy Notice.