Jump to content
Sign in to follow this  
kipersasha

Ошибки после переноса сайта на другой домен

Recommended Posts

Помогите пожалуйста. Переносил сайт с http://saytvverh.ru на https://mirada-spb.ru вроде все сделано как надо. Но вылазит куча ошибок и проблемы с кодировкой... 

Share this post


Link to post
Share on other sites

А как переносили? 

Share this post


Link to post
Share on other sites

1) /config.php и /admin/config.php изменить параметры.

2) Если с root залиты файлы, то нужно своего юзера создавать в панели хостинга

 

Share this post


Link to post
Share on other sites
12 minutes ago, Jozzeff said:

А как переносили? 

 

По классическим инструкциям... база данных... файлы... config.php  

Share this post


Link to post
Share on other sites
22 minutes ago, Rubynoid said:

1) /config.php и /admin/config.php изменить параметры.

2) Если с root залиты файлы, то нужно своего юзера создавать в панели хостинга

 

 

config.php все изменил.

А  что значит root?

Share this post


Link to post
Share on other sites
1 час назад, kipersasha сказал:

А  что значит root?

фильм такой есть - "я есть груут!" :ugeek:

root - это суперпупер пользователь на хостинге, если залить файлы с его правами, то сайт может выдавать ошибки.

Поэтому рекомендуется устанавливать движок, добавлять бд от обычного пользователя на хостинге.

Edited by Rubynoid

Share this post


Link to post
Share on other sites

Я всегда переношу так: 1. Весь движок в архив. 2. Загружаю и распаковываю на хостинге. 3. Изменяю файлы config.php. 4. Создаю базу данных и импортирую в нее уже готовую. Проблем никогда не было.

Share this post


Link to post
Share on other sites

Подскажите, у меня ошибка, может было что-то подобное? Не знаю как решить проблему, суть в следующей с хостинга сайт на https перенес на ОпенСервер, изменил 1) /config.php и /admin/config.php

 

Сделал дамп БД с оф. сайта на https протоколе, перезакачал с сервера на локалку содержимое сайта. Подключил файлы конфига и админ конфига к виду

<?php
// HTTP
$host = $_SERVER['HTTP_HOST'];
define('HTTP_SERVER', 'http://'.$host.'/admin/');
define('HTTP_CATALOG', 'http://'.$host.'/');
define('HTTP_IMAGE', 'http://'.$host.'/image/');

// HTTPS
define('HTTPS_SERVER', 'https://'.$host.'/admin/');
define('HTTPS_CATALOG', 'https://'.$host.'/');
define('HTTPS_IMAGE', 'https://'.$host.'/image/');

// DIR
$dir = dirname(dirname(__FILE__));
define('DIR_APPLICATION', $dir . '/admin/');
define('DIR_SYSTEM', $dir . '/system/');
define('DIR_DATABASE', $dir . '/system/database/');
define('DIR_LANGUAGE', $dir . '/admin/language/');
define('DIR_TEMPLATE', $dir . '/admin/view/template/');
define('DIR_CONFIG', $dir . '/system/config/');
define('DIR_IMAGE', $dir . '/image/');
define('DIR_CACHE', $dir . '/system/cache/');
define('DIR_DOWNLOAD', $dir . '/download/');
define('DIR_LOGS', $dir . '/system/logs/');
define('DIR_CATALOG', $dir . '/catalog/');


// DB
define('DB_DRIVER', 'mysql');
define('DB_HOSTNAME', 'localhost');
define('DB_USERNAME', 'root');
define('DB_PASSWORD', '');
define('DB_DATABASE', 'dum1me');
define('DB_PREFIX', 'oc_');


изменил конфиг файл


<?php
// HTTP
define('HTTP_SERVER', 'http://site.com.ua/');

// HTTPS
define('HTTPS_SERVER', 'https://site.com.ua/');

// DIR
$dir = dirname(__FILE__);
define('DIR_APPLICATION', $dir . '/catalog/');
define('DIR_SYSTEM', $dir . '/system/');
define('DIR_DATABASE', $dir . '/system/database/');
define('DIR_LANGUAGE', $dir . '/catalog/language/');
define('DIR_TEMPLATE', $dir . '/catalog/view/theme/');
define('DIR_CONFIG', $dir . '/system/config/');
define('DIR_IMAGE', $dir . '/image/');
define('DIR_CACHE', $dir . '/system/cache/');
define('DIR_DOWNLOAD', $dir . '/download/');
define('DIR_LOGS', $dir . '/system/logs/');

// DB
define('DB_DRIVER', 'mysql');
define('DB_HOSTNAME', 'localhost');
define('DB_USERNAME', 'root');
define('DB_PASSWORD', '');
define('DB_DATABASE', 'dum1me');
define('DB_PREFIX', 'oc_');
?>

Ну в итоге после подключения через конфиги к бд и запуска сервера сайт віглядит криво.. в какую сторону смотреть, что править нужно? СMS - OpenCart 3.0+
http://joxi.ru/Q2Kb1a7iLbbk4m
http://joxi.ru/vAWdONZTgjj5yr

 

залил просто папку с фхотиснга на локалку .. а сайт изображен криво, как віровнять, ведь на хостинге все ровно?

 

php 5.6

MySql 5.7

Edited by jobplacement

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

On our site, cookies are used and personal data is processed to improve the user interface. To find out what and what personal data we are processing, please go to the link. If you click "I agree," it means that you understand and accept all the conditions specified in this Privacy Notice.