Перейти к содержанию
BZAR

В какой таблице базы данных найти и поменять url сайта

Рекомендуемые сообщения

Здравствуйте!

Сделал тестовый домен и скопировал на него основной сайт.

Импортировал базу данных, поменял в обеих конфигах все url на тестовый домен.

Заменил в конфигах доступы к новой базе данных.

 Итог: в тестовую админку заходит, а вот тестовый сайт в браузере не подгружает, перекидывает на основной.

Думаю, что в базе данных есть строка, где указан главный домен. Подскажите где его найти? Или если не прав, что не так? Заранее всем спасибо за ответ! :))

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

У меня сборка ocStore 2.3.0.2.3

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

нет нигде, смотрите в htaccess

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
24 минуты назад, chukcha сказал:

нет нигде, смотрите в htaccess

 chukcha, спасибо за отклик! Но извиняюсь, в htaccess нет даже записей с названием url домена. Или я не понимаю, где задать команду!?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

1 Удалите временно htaccess

Если ничего не изменилось

2. очитсить storage/modification

Если ничего не изменилось
3 Отключит какие-либо сео модули


 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

В БД ничего нет.
Конфиг веб сервера?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
1 час назад, BZAR сказал:

Здравствуйте!

Сделал тестовый домен и скопировал на него основной сайт.

Импортировал базу данных, поменял в обеих конфигах все url на тестовый домен.

Заменил в конфигах доступы к новой базе данных.

 Итог: в тестовую админку заходит, а вот тестовый сайт в браузере не подгружает, перекидывает на основной.

Думаю, что в базе данных есть строка, где указан главный домен. Подскажите где его найти? Или если не прав, что не так? Заранее всем спасибо за ответ! :))

 

 

Это может быть из-за хостинга и то, что тестовый сайт и рабочий сайт имеют один и тот же айпи. Та же проблема была. Либо не очистили кеш DNS (ipconfig /flushdns).

 

Так все все зависит что за адрес сайта, есть ли у него домен или прописывается доступ через hosts.

Изменено пользователем ActiveSync

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
2 часа назад, BZAR сказал:

Импортировал базу данных, поменял в обеих конфигах все url на тестовый домен.

Заменил в конфигах доступы к новой базе данных.

 Итог: в тестовую админку заходит, а вот тестовый сайт в браузере не подгружает, перекидывает на основной.

внимательно проверьте

config.php

и

/admin/config.php

а так же .htaccess

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Спасибо за советы, пока вопрос не решил, плотно займусь вопросом через пару дней, пообщаюсь с хостингом, как будут новости отпишусь, Еще раз всем Вам спасибо за помощь!

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Друзья, исправил в модуле "мультиязык" домен и всё стало на места! Всем спасибо! Извините за беспокойство! Всем Удачи!

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.