Перейти к содержанию
Xameleon

Перенос товаров

Рекомендуемые сообщения

Вы пытаетесь наложить друг на друга  одинаковые таблицы.Я имел ввиду не восстановление в Система-Резервные копии,а подключение базы данных старого магазина к новому в PhP my admin

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Вы пытаетесь наложить друг на друга  одинаковые таблицы.Я имел ввиду не восстановление в Система-Резервные копии,а подключение базы данных старого магазина к новому в PhP my admin

А вы не подскажете как это сделать?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Создайте пустой магазин с тем же префиксом базы данных, что и старый.То есть установите на чистовую.Потом  на хостинге заходите в PHP my admin  в только что созданную базу нового магазина , выделяете все таблицы УДАЛЯЕТЕ и после сообщения об успешной операции делаете в эту пустую базу данных Импорт базы данных старого магазина.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Большое спасибо за помощь!

А у вас все получилось,а то у меня в такой же ситуации опять ошибки выдает..?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Создайте пустой магазин с тем же префиксом базы данных, что и старый.То есть установите на чистовую.Потом  на хостинге заходите в PHP my admin  в только что созданную базу нового магазина , выделяете все таблицы УДАЛЯЕТЕ и после сообщения об успешной операции делаете в эту пустую базу данных Импорт базы данных старого магазина.

И снова здравствуйте.Я тут ваш совет прочитал,сделал,как вы описали,но у меня опять ошибку выдает в админке вот такого типа:

Notice: Error: Unknown column 'salt' in 'where clause'
Error No: 1054
SELECT * FROM user WHERE username = 'admin_besilver925' AND (password = SHA1(CONCAT(salt, SHA1(CONCAT(salt, SHA1('пароль'))))) OR password = 'e6e086eab4d29969437b4bb9f7c89646') AND status = '1' in /home/users1/t/talvar/domains/besilver925.com/system/database/mysql.php on line 50
Что это может значить?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Видимо вы всё же не совсем так сделали как я написал.Например сама база данных  более старой версии,чем файлы магазина к которым вы пытаетесь её подключить.Решений несколько.Например установить такую же версию движка ну или сейчас просто добавить эти поля в таблицу на которые и ругается ошибка.Сделайте запрос в базу данных  (префикс естественно свой подставить)

ALTER TABLE `oc_affiliate` ADD `salt` varchar(9) COLLATE utf8_general_ci NOT NULL DEFAULT '' after `password`;
ALTER TABLE `oc_customer` ADD `salt` varchar(9) COLLATE utf8_general_ci NOT NULL DEFAULT '' AFTER `password`;
ALTER TABLE `oc_user` ADD `salt` varchar(9) COLLATE utf8_general_ci NOT NULL DEFAULT '' after `password`;

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Этой весной я переносил товары из joomla + virtuemart в opencart. Очень долго искал какие-либо миграторы, но так ничего толком и не нашёл (точнее не нашёл бесплатных или за мало денег). В итоге переносил товары таким образом: Из джумловской базы через phpmyadmin экспортировал таблицы с товарами в формат openoffice calc. Тоже самое сделал с таблицами opencart. Потом по образу таблицы opencart, заполнил её данными из таблицы джумлы. Потом импортировал получившуюся таблицу обратно в opencart. Таким образом, удалось перенести основные данные товаров, включая картинки.

Базу пользователей переносил аналогично.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

 

Видимо вы всё же не совсем так сделали как я написал.Например сама база данных  более старой версии,чем файлы магазина к которым вы пытаетесь её подключить.Решений несколько.Например установить такую же версию движка ну или сейчас просто добавить эти поля в таблицу на которые и ругается ошибка.Сделайте запрос в базу данных  (префикс естественно свой подставить)

ALTER TABLE `oc_affiliate` ADD `salt` varchar(9) COLLATE utf8_general_ci NOT NULL DEFAULT '' after `password`;
ALTER TABLE `oc_customer` ADD `salt` varchar(9) COLLATE utf8_general_ci NOT NULL DEFAULT '' AFTER `password`;
ALTER TABLE `oc_user` ADD `salt` varchar(9) COLLATE utf8_general_ci NOT NULL DEFAULT '' after `password`;

Сделал так-поставил такую же версию движка на новый магазин,удалил все тестовые товары,категории,опции оттуда,через бэкап админки  сделал восстановление,но чудо произошло лишь частичное- встали все категории и товары(ура!) с описанием и даже урлами,но без фото и сейчас если кликнуть в магазине на меню категорий выдает Ошибка 404. Файл не найден.Вот тут я опять в тупик впал.(((

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Есть предчувствие,что еще совсем немного подправить где-то- и все получится.Но вот где?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Раз без фото значит не перенесли папку с картинками.

404 лечится переименование .htaccess.txt   в  .htaccess

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Раз без фото значит не перенесли папку с картинками.

404 лечится переименование .htaccess.txt   в  .htaccess

Папку с картинками скопировал через файловый менеджер на хосте,вроде должно показываться.Но нет...

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Переименовал,404 ушло,но фото все равно нет...Хотя,когда восст-е базы делал через админку фото-то в базе тоже должны были быть?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Ура,понял,в чем ошибка была-я скопировал только те папки,в которых были нужные мне товары,а они,в свою очередь,были в других папках,поэтому пути к картинкам не бились!Для аматора неплохо))

А этот файл htaccess так и оставить с таким названием?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Да.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Да.

Все получилось,о чем спрашивал вас до этого,но после работы в админке и выхода оттуда не могу зайти в админку.(сай нормально отображается при этом)Файлы htaccess и config.php я не изменял. Кэш и куки браузера чистил,каше тоже.Как быть?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

А что пароль меняли перед выходом?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Нет,не менял.Пытался читать тут похожие темы,но так и не понял в чем засада

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

В разных форумах пишут,что хостер мог закрыть доступ из-за того,что модуль автоматической настройки курса валют якобы коннектится к неведомым источникам,но на втором сайте у этого хостера все нормально

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Через PHPMyAdmin поменял пароль,теперь в админку входит,а на сайте при нажатии на любую ссылку 404 ошибку выдает!!!Мозг кипит...

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Решил тупым способом-старый сохраненный файл htaccess вернул в корень,сайт заработал...

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×