Перейти к содержанию

Рекомендуемые сообщения

Установил модуль почты рф, он не стыковался с симплой. удалил вручную симплу и модуль почты. перестал грузиться сайт...

 

HTTP ERROR 500

 

системные файлы не трогал. модули не перезаписывали их... ни админка ни сайт не работают. куда копать ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
7 минут назад, NePridumal сказал:

куда копать ?

Лог ошибок сервера

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Откатите сайт с бекапа, который сделали перед установкой новых модулей. 

Если такого нет то напишите сюда => ссылка

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
1 минуту назад, thentru сказал:

Лог ошибок сервера

на сервере в логах ничего (по делу)

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Как еще продиагностировать лежащий сайт ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
1 минуту назад, prived сказал:

Откатите сайт с бекапа, который сделали перед установкой новых модулей. 

Если такого нет то напишите сюда => ссылка

нету бэкапа( 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
3 минуты назад, NePridumal сказал:

на сервере в логах ничего (по делу)

Включить логирование

Причина 500 ответа должна быть

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

логирование включено в ini файле. админка тоже не доступна.

 

где еще глянуть логи ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

все сделал. в .htaccess надо было включить лги

ошибка была в правке framework файла. для работы старых версий модуля почты

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

1) Файл .htaccess (в конце):

php_flag display_startup_errors on
php_flag display_errors on
php_flag html_errors on

2) Файл php.ini (в конце):

display_errors = On;
error_reporting = ~E_ALL;

3) Файл index.php (после <?php ):

ini_set('error_reporting', E_ALL);
ini_set('display_errors', 1);
ini_set('display_startup_errors', 1);

 

может кому пригодится. как включить логи ошибок

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×