Перейти к содержанию
goldentown

Карта сайта (Sitemap) не отдает ссылки по новому протоколу

Рекомендуемые сообщения

Здраствуйте, такая ситуация случилась, нужен ваш совет. Sitemap сайта не оддает ссылки на новом протоколе (https). на версии 2.3.0.2

 Не могу понять в чем проблема, или сама карта сайта не сразу  формируется? 

Так как один сайт  успешно перевел и все работает но ето было на версии 1.5.5.2 а на 2.3.0.2 проблема.

Сайт получил SSl сертификат, конфіги поменял, работает и на http и на https, robots изменил, у веб мастера занес

 

Или на карту сайта может повлиять то что на версии 1.5 струтура конфигов другая не такая как в 2.3 версии

Конфиги 1.5:

define('HTTP_SERVER',
define('DIR_SERVER_IMAGE'

 

define('HTTPS_SERVER'

 

admin/config

 

define('HTTP_SERVER'
define('HTTP_CATALOG'

 

define('HTTPS_SERVER', ';
define('HTTPS_CATALOG'

 

 

Конфиги к 2.3 версии

 

define('HTTP_SERVER'

 

define('HTTS_SERVER'

 

 

admin/config

 

define('HTTP_SERVER', 
define('HTTP_CATALOG',

 

define('HTTP_SERVER',
define('HTTP_CATALOG',

 

Другой вариант

Eто то что версия 1.5 имеет карту сайта за ссылкой https://site.com/index.php?route=feed/google_sitemap де по аналогии ета ссылка указуется в robots

а версия 2.3  имеет карту сайта за ссылкой https://site.ua/index.php?route=extension/feed/google_sitemap а у robots  указана ссылка другая  https://site.com/index.php?route=feed/google_sitemap(не такая как в моделе карты ) . Может ето повлиять на весь процес или нет 

 

Третий вариант:

Или повлеяло то что , на сайте с версией 1.5 ссылки поменял в базе на https, а у версии 2.3 поменял в базе на относительние через два слеша??????????

 

Четвертий вариант разница у  файле .htaccess проблема с скритием????

 

У Версии 1.5 

 

# Prevent Directoy listing
Options -Indexes

# Prevent Direct Access to files
<FilesMatch "\.(tpl|ini|log)">
 Order deny,allow
 Deny from all
</FilesMatch>

 

 

 

А у версии 2.3 

 

# Prevent Direct Access to files
<FilesMatch "(?i)((\.tpl|\.ini|\.log|(?<!robots)\.txt))">
 Require all denied
## For apache 2.2 and older, replace "Require all denied" with these two lines :
# Order deny,allow
# Deny from all
</FilesMatch>
 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.