Jump to content

Обновление модуля


Сохраните файл стилей catalog/view/javascript/progroman/progroman.city-manager.css, т.к. при обновлении он перепишется.

 

До версии 6.0

Спойлер

Для обновления необходимо удалить старую версию:

  1. Сохраните файл стилей catalog/view/theme/default/stylesheet/geoip.css, может пригодиться при адаптации под тему.
  2. Отключите модуль в админке
  3. Удалите модификаторы, для OpenCart 1.5 vqmod/xml/geoip.xml
  4. Уберите правки из index.php (или system/config/catalog.php для OC 2.2 и выше)
  5. Удалите файлы:
  • admin/controller/module/geoip.php
  • admin/language/russian/module/geoip.php
  • admin/language/english/module/geoip.php
  • admin/model/module/geoip.php
  • admin/view/template/module/geoip/ (всю папку)
  • admin/view/template/module/geoip.tpl
  • catalog/controller/module/geoip.php
  • catalog/language/russian/module/geoip.php
  • catalog/language/english/module/geoip.php
  • catalog/model/module/geoip.php
  • catalog/view/theme/default/template/module/geoip/ (всю папку)
  • catalog/view/theme/default/template/module/geoip.tpl
  • catalog/view/theme/default/stylesheet/geoip.css
  • catalog/view/javascript/jquery/jquery.geoip-module.js
  • system/library/geoip/ (всю папку)
  • system/library/geoip.php

 

Установите новую версию. Таблицы в базе данные: geoip_city, geoip_currency, geoip_redirect, geoip_rule больше не нужны, можете удалить их вручную, установщик скопировал данные из них в новые таблицы.

 

С версии младше 8 до последней

  1. Отключите модуль в списке модулей в админке
  2. В index.php сделайте поиск по файлу строчки с "progroman" и удалите ее (в некоторых версиях ее может и не быть)
  3. Удалите модификаторы
  4. Удалите файл admin/controller/extension/module/progroman_city_manager.php (admin/controller/module/progroman_city_manager.php в Opencart 1.5 - 2.2)
  5. Установите новую версию по инструкции
  6. Включите модуль

 

После обновления модуля до 8.0 можно удалить файлы старой версии, они не используются (необязательно, они ни на что не влияют):

Спойлер

admin/controller/extension/module/progroman_city_manager.php (admin/controller/module/progroman_city_manager.php в Opencart 1.5 - 2.2)

admin/language/(en-gb, ru-ru)/extension/module/progroman_city_manager.php (admin/language/(english, russian)/module/progroman_city_manager.php в Opencart 1.5 - 2.2)

admin/model/extension/module/progroman_city_manager.php

admin/view/template/extension/module/progroman_city_manager.php (admin/view/template/module/progroman_city_manager.php в Opencart 1.5 - 2.2)

 

catalog/controller/extension/module/progroman/city_manager.php

catalog/model/extension/module/progroman/city_manager.php

catalog/language/(en-gb, english, ru-ru, russian)/extension/module/progroman/city_manager.php

catalog/view/theme/default/template/extension/module/progroman/city_manager (вся папка)

catalog/view/javascript/progroman/jquery.progroman.city-manager.js

catalog/view/javascript/progroman/progroman.city-manager.css

 

От >= 8.0 до последней версии

  1. Отключите модуль в списке модулей в админке
  2. Удалите модификаторы
  3. Установите новую версию по инструкции
  4. Включите модуль
  5. Активируйте модуль в админке

×

Important Information

On our site, cookies are used and personal data is processed to improve the user interface. To find out what and what personal data we are processing, please go to the link. If you click "I agree," it means that you understand and accept all the conditions specified in this Privacy Notice.